Need help? Check out our Support site, then


I am unable to publish new blog posts.

  1. New posts will not publish.

    I have tried posting from several computers, and have cleared the browser history and cookies on my computer at home, and have still had no luck with being able to publish new posts.

    When I click the "publish post" button, it says "publishing" with a little timer icon beside it. This timer icon just keeps going and going, and I continue to see "publishing" but the post never publishes.
    Blog url: http://rancegarrison.wordpress.com/

  2. Hi there,

    There's an issue with creating posts on the front page of WordPress.com that will not be fixed until the next upgrade. Do not create posts here > http://wordpress.com/#!/post/

    Instead I recommend that you ONLY create posts here > Dashboard > Posts > All Posts > Add New

    If you are not running one of the browsers and versions listed at http://browsehappy.com/ please try upgrading or switching first.

    Note: If you are using an IE9 browser in compatibility mode that makes it render as IE7 and IE7 is not supported. To disable see > http://www.sevenforums.com/tutorials/1196-internet-explorer-compatibility-view-turn-off.html

    If you are, please do these four things:

    1. Try clearing your browser’s cache http://www.google.com/support/accounts/bin/answer.py?hl=en&answer=32050

    2. Make sure that you have third-party cookies enabled http://en.support.wordpress.com/third-party-cookies/

    3. Try with all browser extensions or add-ons temporarily disabled.

    4. Try enabling HTTPS: http://en.support.wordpress.com/https/

    If you are not successful let us know which browser (and version of it) you’re using and post any error reports you get.

Topic Closed

This topic has been closed to new replies.

About this Topic