Need help? Check out our Support site, then


I disabled comments on a gallery page but it still allows comments

  1. On my gallery page
    http://cathyscholl.com/galleries/comic-con-iphone-portraits/
    I have disabled comments for the page but when I click on an individual image there is a comment area and it allows me to comment…am I the only one allowed to comment or is the "no comment" feature not working? Do I need to disable comments for each individual image somehow?
    Please advise. Thanks.

    The blog I need help with is cathyscholl.com.

  2. Yes, you need to disable comments for each individual image page.

  3. See this post of mine, paragraph that starts with "Currently":
    http://wpbtips.wordpress.com/2009/04/26/images-the-three-link-options/

  4. WHY does everything have to be so complicated?!
    raincoaster and justpi thanks for your replies.
    Panos thanks, once again you have educated me… I at least understand what is happening but I have tried and tried and can't follow your instructions! Has anything changed since you wrote the article?
    I would like to keep the attachment pages but neither option a or b seem to work…
    Could you please try to explain how to disable commenting for an individual image. I'm unchecking comments anywhere I can find them but they are still appearing. Very frustrating…it's 1 am and I've gotten nowhere.

  5. Could you please try to explain how to disable commenting for an individual image.

    When in the Media Library, click the Edit link that appears when hovering your mouse over the image and/or title. There you will see a discussion module and there the possibility to disallow comments by unchecking the box. Save your changes. If you don't see the discussion module, click the Screen Options tab in the upper right corner of the screen to enable it.

    FWIW, in the past we requested that a bulk edit feature be available also for the Media Library, but since that has to be incorporated in the core WordPress program we do not know when and if it will happen.

  6. If you just insert the images into the page and link them to their full-sized counterparts, you avoid this issue entirely.

  7. raincoaster yes I realize that getting rid of the attachment pages would make this issue go away but if I can figure out how to disable comments I'd like to keep the attachment pages. It's a nice looking feature to be able to scroll thru the images. Unfortunately so far I still can't figure out how to get rid of comments

  8. just jennifer UGH. Thanks but I am still lost.
    I'm in Media Library hovering over image. The options are Edit Delete Permanently and View.
    Screen options allows me to Show on Screen-Author/Uploaded to/Comments/Date.
    I've tried checking and unchecking Comments…that does nothing. I've selected Edit in the Media Library, that does nothing. I've pulled up the attachment page and been given the option to Edit it…but nowhere do I have the option to disable comments.

  9. Cathy-you almost got there.

    Media Library>Edit when it appears under the image when hovering your mouse over the name of the image.

    Then, when you are on the Edit Image screen, scroll down until you see the Discussion Module. (screenshot)

    Uncheck the two options in that module and click Update to save your changes.

    If you don't see the Discussion module in the Edit Image screen, click on the "Screen Options" tab in that same screen and check "Discussion". Then follow the instructions above.

  10. justjennifer Got it!!! YAY!!! :) Done!
    Thanks so much for the screenshot and for hanging in there with me.
    I'm very happy I can keep the attachment pages without comments.
    I'm glad I didn't give up.

  11. You're very welcome!

Topic Closed

This topic has been closed to new replies.

About this Topic