Need help? Check out our Support site, then


I want one post to appear on my Posts page. WordPress has other ideas.

  1. I have five posts, each of which is sticky. The rest of my site is pages (it's a clippings and resume site.) I am using ITheme2.

    Each of the sticky posts has a featured image. The slider bar is working fine; the featured image for each sticky post appears on it.

    I have set the Reading settings to "Static Page."

    The "Front Page" is set to my "Personal History" page. This is a page, and it is the first thing I want prospective clients and employers to see when they come to my site.

    The "Posts Page" is set to "Blog Posts." This is for a small number of blog posts, as opposed to the pages, which I'm using as clippings for published work.

    The "Blog pages show at most" setting is set to "1."

    Okay. When I click on Blog Posts, I get the slider bar with all five of my sticky posts, So far, so good.

    Unfortunately, instead of one post, I get them all.

    I just want one post to appear -- not all. That's why I set "Blog pages show at most" to "1," not to "a whole bunch."

    I would also like to be able to choose which post is the one that appears, but right now I'd be happy just to get it to show only one post.

    One. Not many.

    I asked this question in the Forum section, but haven't received any replies, aside from timethief, who said she was flagging it for staff attention. That was 24 hours ago, however, and I figured maybe I should just come to the support section myself to see what happens.

    I had several other problems at the time, but for the moment they seem to be in abeyance. Right now, I just want to concentrate on getting one post to appear when "Blog Posts" is clicked. Not many. Just one. Like I've got in the "Blog pages show at most" under the "Reading" settings.

    As I said, I'm using iTheme2 -- however, I've tried the "Live Preview" for several other themes that support Static Pages and the same thing happens. Each time I click on the Blog Posts page, all the posts show up.

    I think I mentioned that I only want one.

    Thanks for any help you can give.
    Blog url: http://kitsimpson.wordpress.com/

  2. Hi. Just as an experiment, instead of on their own 'static' page, go to your Reading Settings and change it so it's your front page where the blog posts show up (Front page displays: your latest posts)... when I click the 'older posts' link the pages only have the one post on them, so your problem might have something to do with the nature of a static page.

    The only other thing I can think of at the moment is that, having the five posts as "sticky" posts means each post will show up in full on the first blog page, whether it's static or not. This one actually makes more sense. So maybe release two or three of them from being sticky, reload, and see what happens.

    Hopefully someone will come along with a more definitive answer...

  3. Oh, right. And sometimes when I click on "Blog Posts" (like I did a few minutes ago), it tells me "Nothing Found."

  4. Where are your blog posts set to be published right now?

    a. static page
    b. front page

    How many posts do you have set to 'sticky' at the moment?

  5. @feartheseeds

    Here's the information regarding how I have my pages and posts set up, and where:

    I have set the Reading settings to "Static Page."

    The "Front Page" is set to my "Personal History" page. This is a page, and it is the first thing I want prospective clients and employers to see when they come to my site.

    The "Posts Page" is set to "Blog Posts." This is for a small number of blog posts, as opposed to the pages, which I'm using as clippings for published work.

    The "Blog pages show at most" setting is set to "1."

    As for how many posts I have set to "Sticky":

    I have five posts, each of which is sticky. The rest of my site is pages...

    @feartheseeds

    I've done the thing of getting rid of the static page (which isn't how I want my site, but I figured I should look at all the variables), but the same thing happens. Even with it set to 1 post to display, they all show up.

    As for more than one post being sticky -- if they're not sticky, the featured image won't show up in the slider.

  6. I think, and really at this point I'm hoping a moderator will pop in, the problem is the number of sticky posts... a sticky post will appear on the posting page (static or otherwise) in full, unless you use a "more" tag. You have five sticky posts, therefore five posts will appear on your main posting page. Try taking a few off their sticky status and see what happens.

    Fewer sticky posts should mean fewer posts appear on your posting page, if so, you'll know the sticky is the problem.

    I hope this helps, fwiw: I enjoyed reading Ad Nauseum.

  7. if they're not sticky, the featured image won't show up in the slider.

    ...just give it a shot, see what happens. You can always stick them back.

  8. The issue has nothing to do with the static front page: your main posts page works the same, no matter if it's the blog front or not.

    A post cannot show twice on the main posts page, so if you mark all the posts as stickies, then no posts are left for the main column, and you get the Not Found notice. The featured posts slider is meant to showcase some of your posts, not all of them.

  9. @feartheseeds

    I think, and really at this point I'm hoping a moderator will pop in, the problem is the number of sticky posts...

    Oh yeah, I've done that. The result, to say the least, is somewhat confusing. I get only one image in the Featured slider (as could be predicted), and only one post showing up on the Posts page (as could also be predicted). However, the post that shows up on the Posts page is NOT the sticky post. (This is all happening because of Skynet, isn't it? Skynet is becoming aware and is engaging in minor acts of terrorism against humans, starting with me.)

    PS: I'm glad you enjoyed Ad Nauseam.

  10. @justpi

    The issue has nothing to do with the static front page: your main posts page works the same, no matter if it's the blog front or not.

    A post cannot show twice on the main posts page, so if you mark all the posts as stickies, then no posts are left for the main column, and you get the Not Found notice. The featured posts slider is meant to showcase some of your posts, not all of them.

    Not sure what your point is here. When you say that marking all the posts as sticky leaves none for the main column, it sounds like you're saying that the posts that appear in the main column are the ones that are not marked as sticky -- which kind of strikes me as contrary to the point of "sticky."

    It also makes the option of how many posts to display somewhat moot.

    However, I did an experiment. I marked four of the posts as sticky and left one as not sticky. The result was four images in the Featured slider (as predicted), and four posts appearing on the Posts page -- the sticky posts.

  11. New development.

    Since it seems all the posts are going to appear at once, I used the "More" divider so that they're more compact. I want my "Four excellent reasons not to hire me" to appear first, but that seems to be a lost cause. At this point, I was happy (or less disgruntled) just to have them appear in a compact fashion.

    So all posts now have the "More" divider line and all Featured images appear in the Featured slider.

    And only four posts show up on the Posts page.

    Four. And of course, the one that doesn't show up is -- can anyone guess? That's right! It's the one I actually would like to have appear first: "Four excellent reasons not to hire me."

    It's there if I click on its Featured image in the Featured slider, but when I click on "Blog Posts" only the other four show up.

    Skynet really is after me, and it's not fair because I, for one, welcome our new electronic overlords.

  12. Never mind. I fixed it.

    I switched to a different theme.

    Thanks for trying. I really appreciate it.

Topic Closed

This topic has been closed to new replies.

About this Topic