Need help? Check out our Support site, then


I want to block all comments but can't see how to do it

  1. I've received over 400 spam comments on my blog's page, and not only can I not see how to turn them off, when I go onto the dashboard, it has none of the comments listed. I want to block all comments and empty the page.

    The blog I need help with is bernardschaffer.wordpress.com.

  2. Do you actually have 400 spam comments published and showing anywhere on your blog? I think if you have the default Discussion settings, the built-in Akismet comment spam filter should prevent your comments from being posted.
    Basically, what Akismet does is recognize spam posts and put them under the "Spam" on Comments - it doesn't delete the spam posts for you. You can easily do that by going on your dashboard menu -> Comments -> "Spam" and click on "Empty spam".
    However, there are some settings you can check to prevent and control spam comments by going on your dashboard menu -> Settings -> Discussion:

    1. You should always have "An administrator must always approve the comment" checked. That way, no comment - be it spam or not - will appear on your blog unless you approve it.
    2. To further shoo away spammers, you can check "Users must be registered and logged in to comment ". You'll just receive comments from WP users, I believe.

    Apart from this, if you want no comments at all you can: uncheck "Allow people to post comments on new articles"; go to Posts -> check the ones you want -> "Bulk Actions" -> "Edit" -> click "Apply", and on the new section that appears choose "Do not allow" on the dropdown menu labelled as "Comments" and click update.

    Keep in mind: if you don't want to restrict too much who comments on your blog (2), spam comments under Spam will be inevitable, but you can easily delete them by clicking on "Empty Spam". Here is the support page: http://en.support.wordpress.com/unwanted-comments/

Topic Closed

This topic has been closed to new replies.

About this Topic