Need help? Check out our Support site, then


Image and text formatting

  1. Recently, the formatting of my blog posts have gone haywire. Everytime I try to edit a published or unpublished blog post, the spacing between the written content and the photos become lost and squished together with no spacing even though I formatted it as such...and I then have to go back again and space it all out manually...but once saved again, the spacing either takes on a double-spaced appearance rather than single-spaced appearance, or the spacing persists in being squished. Please advise if possible. Thankyou.

    The blog I need help with is momoandcoco.wordpress.com.

  2. *Update: I followed this help guide (http://onecoolsitebloggingtips.com/2011/09/13/wordpress-formatting-and-spacing/) and my text formatting is mostly ok now, but image formatting is still strange. I cannot seem to get any consistent spacing between images at all. It affects my published March posts, and unpublished posts. Please assist Thankyou

  3. Please be specific: link or point to specific posts and tell us exactly what you'd like to change.

  4. Hi

    Thanks for your reply. The issue is that I cant seem to format my pictures to have a double space or single space in between each picture. The case is twofold: either i am able to insert a space but when I save changes and preview, that formatting disappears; or i simply cannot insert a space between the images no matter how many times I press "enter." I used to be able to do it on my past blog posts but all my blog posts published this month and those blog posts in unpublished draft stage are suffering from the same format issues. Here are the blog posts with spacing formatting issues that were published this month. Please let me know if this clarifies, apologies I am a relatively inexperienced blogger. Thankyou

    http://momoandcoco.wordpress.com/2012/03/08/jamies-italian/

    http://momoandcoco.wordpress.com/2012/03/08/chefs-gallery/

    http://momoandcoco.wordpress.com/2012/03/08/jamies-italian/

  5. Pressing return repeatedly will never give you correct results, for various reasons.

    The way the theme you're using is designed, to control the space above or below a captioned image you need to switch the editor to HTML and paste this:
    <div style="height:8px;visibility:hidden;">-</div>
    Change the number to adjust the space.

    The theme you're using has another issue as well: notice how all your right-side borders are wrong? For captioned images that should cover the whole width of your posts, you need to go to Settings > Media, set the width for the Large option to 608 and the height to 0, and select the Large instead of the Full Size option when inserting the images. Then you need to switch the editor to HTML and change the first 608 in the code to 622.
    Same thing for smaller captioned images: the first width number in the code must be increased by 14.

    If you wish to correct your already published posts, you must change the code of all the full-size captioned so that it becomes like this:
    [caption id="attachment_NUMBER HERE" align="aligncenter" width="622" caption="CAPTION HERE"]<img class="size-full wp-image-NUMBER HERE" title="TITLE HERE.jpg" src="IMAGE URL HERE?w=608" alt="" width="608" />[/caption]
    (First width number 622, second and third width numbers 608, no height indications.)

    But it would be better if you used an image editing application to scale down copies of your images to 608px wide, and upload and insert those copies. This way you can use the Full Size option and forget about the numbers (except the first one), you won't waste your storage space by unnecessarily uploading the large files you've been uploading, and your pages will load faster. Plus you'll get better quality, because images downsized by WP lose some color and sharpness; see here:
    http://wpbtips.wordpress.com/2010/01/16/image-quality/

  6. Thanks for your reply! That's seems rather complicated! It is strange but only two weeks ago or so, I was able to insert spaces between my images by simply pressing "enter" and I never had to switch between the Visual Editor and the HTML Editor. How then can it be that you say that pressing "enter" won't create a spacing because the theme of my blog is not set up in that way?

    With regards to re-sizing my photos as you instructed above, do you mean that I edit each of my blog posts and insert that HTML code in the HTML Editor for each and every image?

    A friend just told me that it might be a browser issue but I have since emptied all the cookies etc and downloaded any any updates so I don't think it can be that. What do you think?

    Thankyou!

  7. a) Yes it's complicated, because the theme you're using is faulty: it doesn't take into account the image borders it creates. You can report this to the Themes forum and hope that WP will make the theme understand how its own images are displayed, or you can switch to a better theme.

    b) I didn't say pressing enter won't create a spacing, I said "pressing return repeatedly will never give you correct results, for various reasons" (hoping I could avoid elaborating on the reasons).
    - The web standard is no multiple horizontal spaces or multiple blank lines, so normally they are stripped out upon save or if you switch between HTML and Visual editor.
    - Pressing return, repeatedly or not, may survive and may work, depending on whether the section you're on is formatted as a paragraph or not, and depending on the image alignment.
    - Pressing return, repeatedly or not, may give you the illusion it's working but may prove wrong as soon as you switch to a theme with a different column width.
    - WP changes things all the time.

    c) No, I didn't mean insert that code: that type of code is already there in your HTML editor. I meant you'd have to modify it as suggested.

Topic Closed

This topic has been closed to new replies.

About this Topic