Need help? Check out our Support site, then


Image click maps and image adding

  1. I have those problems with images:

    1.I tried adding <map> tags to the html, because I have a picture with a graph, and some parts of the graph need to link to specified places in my blog. But <map> tag is removed. Is there reason for this ? (probably this might be request to to allow map tag)

    2.I create new page, upload image, then put it in the wysiwyg view through the click-the-picture options,then I try to see the HTML, and when I return instead of the picture, in the wysiwyg view there is little picture placeholder with the name of the picture in it, and when i get back after that to simple HTML editor, the src attribute is missing from the <img>

  2. 1 - Try using the normal editor for map tags. I see a mention over on the WP.org support forum that leads me to believe that TinyMCE may be stripping it out on you. Never tried using a map tag before within a post so I couldn't tell you. I'll drop a post in my support forum just to see if anyoen else has. Used a lot in headers. Never seen it in posts though.

    2 - Don't use the rich editor. I know that that's a crappy response but so is TinyMCE. Your best bet is just to click on "Save and Continue Editing" every once in a while. Your post will reload on the bottom half of the page and you can go from there.

    Good luck,
    -drmike

  3. I see that the thread on the WP.org support forum has been closed and marked as resolved, but I am still having the same problem as the above user describes in #1 when trying to post image maps. I disabled the rich/WYSIWYG editor and switched to the normal editor as suggested, but it still strips out the map tags.

    Any ideas?

  4. Since those answers, we've received a list of what tags are allowed. Maps aren't on that list I'm afraid and, as you state, are stripped out.

    Best bet would be to send in a Feedback and ask if they can be put on the allowed list. I'm guessing it's for security reasons but I can't think of any of the top of my head. Doesn't mean they're not out there though.

  5. I've just encountered this problem. Even with MCE turned off, <map> is stripped. Is there NO way around this?

  6. swein - I will find out.

Topic Closed

This topic has been closed to new replies.

About this Topic