Need help? Check out our Support site, then


Image doesn't appear in post

  1. I can't get an image to appear in a post on my home page (http://newsenterprise.wordpress.com). It shows up on the read more page (http://newsenterprise.wordpress.com/2011/06/25/coming-soon-5/) but not on the main page.
    In addition, even when the image does appear on the read more page, the text does not wrap around it, as formatted. Instead, the image appears under that text. Does anyone know how to sort this out?
    Thanks.

    The blog I need help with is newsenterprise.wordpress.com.

  2. Try putting the image BEFORE the text. That might make it show up, OR that could be one of those themes where you have to choose a Featured Image or it won't show on the front page. If doing the first suggestion doesn't fix it, try inserting it and selecting it as a Featured Image.

  3. a) setting the image alignment to left (or right) means that the rest of the content will wrap around. So, to make the text wrap around, you must place theimage before the text, not after it.

    b) To make the image show up on your homepage, you've got three options:
    • Set the homepage to display full posts instead of excerpts (Appearance > Theme Options).
    • Copy the content of the post from the HTML editor and paste it into the Excerpt field. If you're not seeing the Excerpt module while on the post editor screen, click Screen Options (top right) to activate it.
    • Set the image as a featured image.

    More details on this theme here:
    http://wpbtips.wordpress.com/2011/06/02/the-morning-after/

  4. I tried putting the image in first, but then I couldn't write in the text box, only in the image box. The first time I tried this, the text wrapped around but the image overlapped the text slightly. Now I can't get it to wrap at all, or insert text in the text box.
    Also, do I understand correctly that I can't get an image in each of the article on my homepage? Can this be fixed?

  5. PS--The link you sent shows a home page with multiple posts, each with an image in the left corner. How do you do that in reality?

  6. Align the image to the left. If you're having difficulty separating the text and the caption, then click to the HTML editor and type in that. I've noticed the same error using Chrome.

  7. Thanks. But the Image IS aligned left. I have no idea how to use HTML. In addition to all the other problems, only on post shows up on the home page. I tried Woo Themes or whatever it's called and they want hundreds of dollars to sign up for support. This is simply idiotic. Why in the world doesn't wp provide support?

  8. How about actually reading the post I linked to? It includes all you need to know about how this theme works.

  9. I did read it. It doesn't say anything about images not showing up in posts. I also tried making the post a feature. That didn't work either. Nor does any of this explain why only one post shows up on the home page at a time.
    I also tried your suggestions.

  10. You do not need to know how to use HTML.

    You need to put the image in, then click to the HTML editor, then put in the text, after all the tags and such, all the code. That keeps it separate from the image. THen click back to the Visual editor to finish the post.

  11. It doesn't say anything about those things? Really?

    Quoting from my post:

    Upper section: latest post.
    Middle section: “featured” posts (enclosed in a grey background).
    [...]
    Featured posts are any number of posts you decide to showcase by marking them as stickies.

    The latest post and the featured posts can show up in full* or as an excerpt; option set in Appearance > Theme Options > General. The excerpt can be auto (beginning of post, text only), or custom, if you add content to the Excerpt field of the post editor.
    [...]
    If you set a featured image to your posts, the latest post will display that image above the post title [...]; the featured posts will include that image as a square thumbnail [...].
    If you want images on the homepage but don’t like where and how the featured images are displayed, you can use regularly inserted ones instead, if you choose to display full posts, or include the image HTML in the Excerpt field, if you choose to display excerpts.

    (Items in bold are links to the relevant Support docs.)

  12. Yes, it says that. I tried making it a feature post. The image still didn't show up in the post. The images in the link you sent show posts on the home page with pix in them but it doesn't work in reality.

  13. Raincoaster: Thanks. Before I got your latest reply, I figured out part of the problem. It was that caption. That's what stopped the image from aligning properly. I removed the caption and the image now aligns correctly in the read more view, but it still doesn't show up in on the home page. I tried your suggestion of inserting the text in HTML view, but got the same result. For some reason images just do not show up on the home page and only one post shows up there at time.

  14. For an image to show up, you need to do one of the three things I mentioned in my first reply. Neither that reply nor my article on TMA says make the post a featured post to get the image.

    And check a blog that uses this theme to see the real reality:
    http://blog.vivianpaige.com/

Topic Closed

This topic has been closed to new replies.

About this Topic