Need help? Check out our Support site, then


Image not showing ok for FB share & Widgets/Top posts/Pages (set to show image)

  1. Widgets, have TOP POSTS & PAGES set to show image. It used to work, now it just shows my image for all... (changed it to text for now, but would really like that back!) Also, when sharing to Facebook... the thumbnail isn't available, only shows my image. This happened several days ago and is still not working. Has been fine forever. http://barbarastroud.wordpress.com

    The blog I need help with is barbarastroud.wordpress.com.

  2. Everything was working fine. Starting a few days ago images are not showing correctly on my blog (http://barbarastroud.wordpress.com). When Facebook shares my post, the thumbnail isn't correct, it's a photo of me, instead of from the post that day. Also, I had Widgets/ Top Posts&Pages set to show image, and that was working great. Now it shows ten photos (all the same) of me. Have changed to text for now. What has happened. Cleared cache, no change.

  3. Note: Image is an older image as well, not my current profile pic in WordPress...

  4. Please see the sticky post at the top of the forums:
    http://en.forums.wordpress.com/topic/problems-with-top-posts-and-pages-widget?replies=56

    The widget is broken. Staff is working to solve the problem.

  5. THANK YOU!

  6. You are welcome. I also hope they can fix it soon!

  7. Thanks for all the report on this issue. Our developers are aware of the problem and we will post updates on this thread:

    http://en.forums.wordpress.com/topic/problems-with-top-posts-and-pages-widget

    This duplicate thread will be closed.

Topic Closed

This topic has been closed to new replies.

About this Topic