Need help? Check out our Support site, then


IMAGE RESIZE: No longer works, bah humbug!

  1. My blog's theme's fullest width is 800px. Usually that is the size of the images I upload from my PC, unless they are naturally smaller than that or sometimes larger. The system would automatically select a size to insert into the post. Then I would resize it within Text mode, ie change the width, height and width, and so on. The changed size is reflected in Visual mode and is obvious. Sweet! I didn't need to preview the post as I was confident it would look as per the changes I'd made (apart from the fact, I can no longer preview my posts anyway....but that is another matter!).

    I currently have a published post which looks slightly fuzzy anyway, as it is a 16:9 aspect ratio image prepared in Picasa as a collage. I had decided to reduce the size to crisp it up a little, and when I was within the Edit Post >Text mode, I changed its proportion to 648x365px (the original being 800x450px). The change was obvious within the Edit Post mode. However, when checking it on the blog itself, it still looks the same and, therefore, I decided to right-click the image and check on Properties to see what it said. Here is the info: http://jmnartsy.files.wordpress.com/2012/11/1-maxtor-origs11.jpg?w=840.

    Can I presume the w=840 refers to the width of the image, and has been added by the WP system, somehow, as the original link detail ends at .jpg. Yet, part of the Properties info. indicated that the image dimension was 800x450px!

    Why has my resizing not been applied?

    The image I refer to above is the second image, which I had to upload again from my PC and insert into the post. Because I had gone back into Edit Image mode within the Media Library and tried the new Scale Image process, but once I pressed the Scale button, it produced a very tiny image-holder with a red x inside it; No Image! L>O>L!!! At that point, I wasn't aware of the Undo process (I've just read about it within these Forums).

    Does this mean, now, that I will no longer be able to change image sizes after upload?

    Does this mean, then, that I will have to be definitely certain of the size I want my images to be, before uploading, and resize them to that size on my PC, as the Scale Image function does not work?

    The blog I need help with is jmnartsy.com.

  2. • The post editor is a generic tool: it has a fixed width, and it works the same no matter what the theme (with some exceptions) - it does not necessarily reflect what you'll actually see on the published post.
    • The "?w=NNN" is added to image URLs to limit images to the maximum width a theme allows. This happens in all themes (with different numbers, of course) and it's not new. It affects images only if they are wider than the maximum: the URL of a 800px wide image with "?w=840" at the end produces a 800px image.
    • Maximum width in Duotone is 840px for landscape-shaped images and 560px for portrait-shaped or square images. Image resizing never worked in Monotone and Duotone: if the original file is narrower than the allowed maximum, it displays at original size no matter what you do with the coding; if it's wider than the allowed maximum, it's downsized to that maximum, again no matter what you do with the coding. Check note 4 here (and note that my post dates from 2009):
    http://wpbtips.wordpress.com/2009/07/23/maximum-image-width/

  3. Thank you, justpi, for your input.

    Since my posting, I have done some testing and have decided that, for any new posts I wish to prepare from now on, I will upload the image first and save it to the Media Library. Then, when I am ready to prepare a Draft post, I will press Add Media above the post editor and find the uploaded image and just insert into the post. That way, I get my full-sized image as uploaded.

    This is not the process I have used prior to now. Live and learn, eh! :O)

  4. When I resize the image in article editor, it never works with the final article - the image is displayed in its full size. I found out that editing the image and deleting "full width" parameter from the CSS Class line helps. The image then shows in the size I want.

  5. @jmnartsy:
    You're welcome.
    The way you use to insert the image should make no difference: you'll get your "full-sized image as uploaded" as long as it's not wider than the allowed maximum.

    @helar:
    a) You're using a 'normal' theme. Jmnartsy's question was specifically about Duotone, which works unlike any other wordpress.com theme.
    b) If you have difficulties resizing an image, the surefire way is to delete the regular width and height commands and add the desired width in the style attribute. For example, you turn this:
    <img class="ETC" alt="ETC" src="IMAGE URL" height="WHATEVER" width="WHATEVER" />
    to this:
    <img style="width:394px;" class="ETC" alt="ETC" src="IMAGE URL" />

Topic Closed

This topic has been closed to new replies.

About this Topic