Need help? Check out our Support site, then


Images not displaying when posts are listed on home page

  1. For posts with images, the images are not displaying when posts are listed on home page. This seems to be a bug that has taken root in the past month - previous posts that include images display an image on the home page. This is not a "featured image" issue - I am not trying to customize the header. And it is not a browser or caching issue - it happens across browsers and machines.

    The blog I need help with is nhmilw.wordpress.com.

  2. The template is Triton Lite

  3. I am using Firefox 20 and IE8 and I see slideshows and videos in the posts on the front page here http://ilcmilwaukee.wordpress.com/
    If that's not the blog in question then please post the URL starting with http:// for the blog you are referring to. If that is the blog you are referring to then you have a browser related issue.

    If you are not running one of the browsers and versions listed at http://browsehappy.com/ please try upgrading or switching first.

    Note: If you are using an IE9 browser in compatibility mode that makes it render as IE7 and IE7 is not supported. To disable see > http://www.sevenforums.com/tutorials/1196-internet-explorer-compatibility-view-turn-off.html

    If you are running one of the browsers and versions listed at http://browsehappy.com please do these four things:

    1. Try clearing your browser’s cache:

    http://www.google.com/support/accounts/bin/answer.py?hl=en&answer=32050

    2. Make sure that you have third-party cookies enabled: http://en.support.wordpress.com/third-party-cookies/

    3. Try with all browser extensions or add-ons temporarily disabled.

    4. Try enabling HTTPS: http://en.support.wordpress.com/https/

    If it’s still happening, let us know exactly which browser (and version of it) you’re using by checking here if necessary http://www.whatbrowser.org/ and also post any error reports you get.

  4. The template is Triton Lite

    And the URL for the blog starting with http:// is?

  5. For posts with images, the images are not displaying when posts are listed on home page.

    I am using Firefox 20 and IE8 and I don't see this issue you report. I see images in every post on the front page.

    If you are not running one of the browsers and versions listed at http://browsehappy.com/ please try upgrading or switching first.

    Note: If you are using an IE9 browser in compatibility mode that makes it render as IE7 and IE7 is not supported. To disable see > http://www.sevenforums.com/tutorials/1196-internet-explorer-compatibility-view-turn-off.html

    If you are running one of the browsers and versions listed at http://browsehappy.com please do these four things:

    1. Try clearing your browser’s cache:

    http://www.google.com/support/accounts/bin/answer.py?hl=en&answer=32050

    2. Make sure that you have third-party cookies enabled: http://en.support.wordpress.com/third-party-cookies/

    3. Try with all browser extensions or add-ons temporarily disabled.

    4. Try enabling HTTPS: http://en.support.wordpress.com/https/

    If it’s still happening, let us know exactly which browser (and version of it) you’re using by checking here if necessary http://www.whatbrowser.org/ and also post any error reports you get.

  6. The blog I am referring to is:
    http://nhmilw.wordpress.com/

    The browser is not the issue - the problem occurs across browsers and platforms.

  7. I see the images just fine too: http://d.pr/i/axrH/5HIvEKv7

    First, please make sure that your browser is up to date by visiting http://whatbrowser.org/

    If it is not, please try updating your browser or switching to a different browser.

    If it is, please do these four things:

    1. Try clearing your browser's cache and cookies: http://en.support.wordpress.com/browser-issues/

    2. Make sure that you have third-party cookies enabled: http://en.support.wordpress.com/third-party-cookies/

    3. Try with all browser extensions or add-ons temporarily disabled.

    4. Try enabling HTTPS: http://en.support.wordpress.com/https/

    Please let us know how each step goes for you, and which browser (and version of) you're using if you're still having trouble.

  8. The most recent two stories -- "Grow with us" and "An ordinary extraordinary day" --- did not display images on the home page, though they are structured no differently than other posts. This problem is a recent development. I have deleted them and reported them, to no avail.

  9. In that template, featured image creates a customized header with a slide show of images from different posts. None of the posts currently have featured images. They do, however, show images on the home page. Except the two most recent, which are not coded any differently. It seems like a bug.

  10. Ah, ok.

    The big different that I see between those two posts and the rest is that they start with text, while the others start with the images or video.

    Try re-saving them with the images first.

  11. I re-saved them with the images first, but it hasn't solved the problem.

    I've a rebuilt them a number of times, sometimes from scratch, sometimes copying code from previous posts that do function properly. I've also tried deleting the images and re-uploading them.

  12. Ok, I'm sorry I didn't notice this sooner.

    The images on the posts in question are not attached to the posts.

    In order to attach an image to a post, it needs to be uploaded via the "Add Media" button while writing or editing the specific post.

    Triton Lite will display the Featured Image first, and if there is none, it will display the first image attached to the post. Without either, it will display nothing.

    So, in this case, all you need to do is edit the two posts and upload the images again via the "Add Media" button while editing the posts.

  13. Thanks, this helped.
    On the page with the slideshow, I actually had to insert an image above the slideshow, save the page, then delete the extra image and save again. I don't remember doing this with earlier posts. But the problem is solved.

  14. You're welcome!

Topic Closed

This topic has been closed to new replies.

About this Topic