Need help? Check out our Support site, then


Images not showing

  1. I have a photo-blog, and my images won't show up. Sometimes, if I refresh about 20 times, some of them will load. Is anyone else having this problem or know the solution?
    Thanks
    Blog url: http://bathshebafournierphotos.wordpress.com/

  2. I see your images. I'm using FF 16.0.1
    Did you upload the images into your Media Library ie. are the images on WordPress.com servers? Or are they hosted on third party sites like photobucket or Flickr or on other sites on the web?

    If you are not running one of the browsers and versions listed at http://browsehappy.com/ please try upgrading or switching first.

    If you are, please do these:
    (1) Try clearing your browser’s cache:
    http://www.google.com/support/accounts/bin/answer.py?hl=en&answer=32050
    Note: If you are using an IE9 browser in compatibility mode that makes it render as IE7 and IE7 is not supported. To disable see > http://www.sevenforums.com/tutorials/1196-internet-explorer-compatibility-view-turn-off.html

    (2) Try with all browser extensions or add-ons temporarily disabled.

    (3) More on the options for uploading images:
    http://wpbtips.wordpress.com/2009/04/26/images-the-three-link-options/

    (4) For troubleshooting images here > http://en.support.wordpress.com/images/troubleshooting-images/

    If you aren't successful let us know which browser (and version of it) you’re using and post any error reports you get.

Topic Closed

This topic has been closed to new replies.

About this Topic