Need help? Check out our Support site, then


Images not shown when sharing on Facebook

  1. Lately, when I share my posts on Facebook, the image / thumbnail does not show up. This used to work. And it is only true for this wordpress blog (I have a Blogger blog that still shows the images on FB).

    The blog I need help with is missionallendale.wordpress.com.

  2. Thanks. I left a comment there asking for help. The question isn't about my blog & FB being linked (& Publicizing automatically). The problem is when I copy/paste the URL in my status.

  3. Well copy and paste the image URL as well as the post URL or not? Unfortunately, we have no control over the images that Facebook chooses to display or when they choose to flush their image caches. We really only send them the URL of the post, and they hunt through that for the excerpt and images to include. From: http://en.forums.wordpress.com/topic/avalaible-facebook-thumbnail-issue?replies=7#post-1000734
    Read also: http://developers.facebook.com/tools/debug
    from: http://en.forums.wordpress.com/topic/fb-link-has-no-thumbnails?replies=4#post-936861

  4. @joeyespinosa I tried sharing a few of your posts, and the images seemed to appear properly:
    http://i.wpne.ws/OAIt

    As @timethief mentioned, if you experience issues with some of your posts, it might be worth entering the post URL in the Facebook Debugger. It will clear Facebook's cache for that page, and force Facebook to crawl the page once again to look for a title, a description, and images.

  5. Thanks for the tips. I'll give it a shot.

Topic Closed

This topic has been closed to new replies.

About this Topic