Need help? Check out our Support site, then


Images shrink after upload

  1. When ever I upload the images to a post or a page, the image size shrinks. After adding an image I have to go back to it, increase the size to 130%, that's when I see it as big as the post width. Can any one tell me why is this happening? How can I retrain image size?

    The blog I need help with is thereddotman.com.

  2. The blog you specified at thereddotman.com does not appear to be hosted at WordPress.com.

    This support forum is for blogs hosted at WordPress.com. If your question is about a self-hosted WordPress blog then you'll find help at the WordPress.org forums.

    If you don't understand the difference between WordPress.com and WordPress.org, you may find this information helpful.

    If you forgot to include a link to your blog, you can reply and include it below. It'll help people to answer your question.

    This is an automated message.

  3. My blog is very much hosted at wordpress.com. I just recently made the move.

  4. Bot fail!
    You have the Custom Design upgrade, and you have increased the default post width. Did you increase the "content width" for images etc accordingly? (Appearance > Custom Design > CSS > Content Width)

  5. Nope, that doesn't seem to be working. It's having no effect when I input the pixels in the px box. However, I went in to the code and changed the width. What's happening is along with the images, even the smileys are getting blown up to full post width.

  6. First of all, read this post of mine:
    http://wpbtips.wordpress.com/2013/02/21/where-is-the-theme-css-and-how-do-i-edit-it/
    You should either delete everything from the CSS editor and add only the specific changes you make, or at least (if you insist on keeping the entire stylesheet in the editor) check the option "Don't use the theme's original CSS."

    Second, I checked the image codes in your latest two posts, and they aren't ok: the size command is missing from the class attribute, and the dimensions are wrong (width 1248px instead of 900px). Did you make these changes yourself in the Text editor? Can you give us the URL of a post in which the image wasn't inserted in the size you wanted but you didn't "increase the size to 130%"?

  7. I didn't edit the width. But like you said I did increase the image size to 130%. Here's a post in which I didn't do this. http://thereddotman.com/2013/04/12/death-darksiders2-art/

  8. a) The images on that post behave as expected when you haven't taken care of what I originally suggested: they display at the default max-width for TL (620px).
    b) You disregarded the first paragraph of my previous rely. At the moment browsers are reading two stylesheets (the original plus your modified version of it), and this can create conflicts.

    So let me check that post again after you go to the CSS editor, enter 900 in the Content Width field, check the option "Don't use the theme's original CSS", click Save.

  9. Ah!! That worked. And yes I seem to have over looked the first para of your reply. Now the images are appearing to their regular size. Thank you. Thank you so much.

  10. You're welcome!

    Extra tip:
    Many of the images you insert are wider than 900px, and they get downsized to fit. But images downsized by WP lose some color and sharpness - see this post of mine for an example:
    http://wpbtips.wordpress.com/2010/01/16/image-quality/
    So, if you want best quality on the post, you should use an image editing application to downsize copies of the originals to 900px, and upload/insert those copies instead of the oversized originals.

  11. Got it. That will really help me as my blog revolves around digital art and photography. Thanks so much.

Topic Closed

This topic has been closed to new replies.

About this Topic