Need help? Check out our Support site, then


Images won't display properly

  1. I've been running my WordPress site for about eight or nine months now. About a week ago, I started to experience a problem. I've been doing everything as I usually do. I upload images into my posts, edit their size by dragging the corner, of the image and arranging them appropriately. I also source them. I've done this on pages, as well as posts, and it's always worked fine.

    Now when I do the exact same thing, it shows perfectly in the edit part, then when I hit preview or publish and view it, the images change size completely and distort all of the text and make everything look terrible. I have no idea if this is a WordPress change or if this is something I'm doing differently, but I really need help?

    It's making me so angry. Thank you for reading.

    The blog I need help with is therealmidcard.wordpress.com.

  2. I had this problem once, and I had to clear my internet cache.

  3. A change was made to how images are resized. The settings on the Settings > Media page in your blog dashboard will now override other settings unless you have modified the image's CSS classes via the HTML editor. That change was made on 20 Sep 2013.

    The problem where the images in the editor appear differently than on the blog's front-end is a bug. We're working to find the right solution for that issue, and I will post back here as soon as I have an update.

  4. therealmidcard
    Member

    Thanks a lot. I really don't know how to go about doing things as normal again, so any help you can offer would be greatly appreciated.

  5. Sure!

    I usually do. I upload images into my posts, edit their size by dragging the corner, of the image and arranging them appropriately.

    I don't know if dragging to resize images will always work, and dragging to resize might be pretty unreliable in some browsers (at least that's my past experience).

    To size images, you should update your Media > Settings page with the thumbnail, medium, and large sizes you want to use and then select one of those when you insert the image. See #7 in this screenshot example: http://en.support.files.wordpress.com/2009/08/image-settings1.png

    I also source them.

    I'm not sure what you mean.

    I've done this on pages, as well as posts, and it's always worked fine.

    Sometimes changes are made. You should follow the support docs. If something doesn't work according to the support doc, contact support and they should look into it.

    Try updating the Media > Settings first. That is the best place to start.

  6. On all my past posts (and now present) text is covering a portion of my images. Also the images have gotten larger than originally set.

    An example of what has happened can be seen here: http://answersforactors.wordpress.com/2013/08/27/how-not-to-contact-a-casting-director/

    The picture was never that large. And the text was set to align left.

    Help?

  7. therealmidcard
    Member

    I've started clicking on the image, and adapting the width and height of each one as precisely as I want. They now display as I want, the same in the editor as the actual site.

    Thanks for the help!

  8. @prcasting, that is a bug happening with captioned images. Sorry for the trouble! I'll post back here as soon as I have more information on that issue.

  9. @prcasting, I checked http://answersforactors.wordpress.com/2013/08/27/how-not-to-contact-a-casting-director/ today after an update we made, and it looks better, but we're still working on captions.

Topic Closed

This topic has been closed to new replies.

About this Topic