Need help? Check out our Support site, then


Impossible to Make Line Breaks in Posts

  1. Prior to this month, I never had trouble separating paragraphs in my posts but lately, even when it all looks as I'd like it to in my editing stage, as soon as I publish my words and lines all get squashed together. HTML tags do nothing. I'm not an experienced web designer by any means - I just blog. I don't think it ought to be so hard to just make a page break - even someone like me should be able to do it. Regardless, what's going wrong and how do I fix this? It would be nice to be able to just write and edit a post in my own blogging platform without having to cut and paste it into word to even make the changes stick ... thank you for any advice!!!

  2. What operating system and browser/version are you using? Just as a note, cutting and pasting from word will lead to problems typically since word puts in all sorts of weird code.

  3. Have you tried
    <br>

    Example 1:

    <p>Acme Products<br />
       123 Runner Road<br />
       Coyote, Texas 76543</p>

    Example 2:
    `<p>I think that I shall never see
    A poem lovely as a tree.</p>
    <p>A tree whose hungry mouth is prest
    Against the sweet earth’s flowing breast;</p>'

  4. The code didn't take in the second example even though it was between backticks. I'll try again.

    <p>I think that I shall never see<br />
       A poem lovely as a tree.</p>
    <p>A tree whose hungry mouth is prest<br />
       Against the sweet earth’s flowing breast;</p>
  5. Or do you really mean page break?
    The end of a page of text. In word-processing systems, you can enter special codes, called hard page breaks or forced page breaks, that cause the printer to advance to the next page. Without hard page breaks, the word processor automatically begins a new page after a page has been filled (this depends on the number of lines per page). In this case, the page break is called a soft page break.

  6. hi, folks - thanks for your input. I'm working on a MAC, using Safari. Not page breaks, thistimethisspace - I mean...

    this.

    ;)

    That's what I can't do on my page. I had tried using the classic <br> and < / br> tags but they didn't do anything - only appeared as part of the squashed up text. Let me go try with the other tags but I have a suspicion they won't work if the <br> tags don't ....

  7. ieatmypigeon,

    could you please try
    <p> </p>

    it works for me! :D

  8. Safari is the problem as it is not fully supported by the TinyMCE editor used by wordpress. My suggestion would be to either turn off the visual rich text editor or to switch to FireFox. Switching to FF will fix other problems that you may not have run into yet. With FF you can use the visual rich text editor and you will have paragraph breaks as you wish.

  9. Which Safari?

    As I understand it we have:
    Leopard, Tiger, Tiger beta, Windows beta.
    4 versions.

    When Apple decide to not have such a wild variety of browsers then Tinymce - who code our editor - can probably start addressing any quirks.

  10. The question appears to be:

    I don't think it ought to be so hard to just make a page break - even someone like me should be able to do it.

    However, I do not think that it's really "a page break" that ieatmypigeon is asking about. I believe he or she is asking about line breaks and paragraph breaks. And I believe from what I read above that there is a browser issue here.

    It's my understanding (staff are free to correct me if I'm wrong)
    that
    <br> creates a line break
    <p> paragraph</p> is a paragraph break
    <p> </p> creates both a paragraph break and a extra second blank line between paragraphs

  11. The question appears to be:

    I don't think it ought to be so hard to just make a page break - even someone like me should be able to do it.

    However, I do not think that it's really "a page break" that ieatmypigeon is asking about. I believe he or she is asking about line breaks and paragraph breaks. And I believe from what I read above that there is a browser issue here.

    It's my understanding (staff are free to correct me if I'm wrong)
    that
    <br> creates a line break
    <p> paragraph</p> is a paragraph break
    <p> </p> creates both a paragraph break and a extra second blank line between paragraphs

  12. safari! darnit. all right ... i read some other posts about turning off the rich text editor but i'm not sure how to do that. and can i do firefox on a mac? do i have to download it or do something funny to get it on there? sigh. sorry for what no doubt seem to be ridiculous questions - like i said, I just blog here.

  13. Unfortunately the blockquoted text I referred to above did not appear when I posted it.

    Quoting ieatmypigeon:

    " I don't think it ought to be so hard to just make a page break - even someone like me should be able to do it. "

  14. Turn it off on this page -> Your Profile and click "Update Profile" to save the change.

  15. @ieatmypigeon

    If you're using Tiger with Safari 3 beta, you could uninstall it and revert back to Safari 2. That doesn't have the same problem. Firefox works, as do Bon Echo and Camino which are both based on the Mozilla engine but "tweaked" for Mac.

  16. it does not matter.

    all them are powered by the WebKit -- a free open-source engine, which, besides Safari, is also used as a browser platform in the Nokia S60 series browser and in the open-source Google's Android toolkit.

    just the basic facts:

    * WebKit for Safari is the same as Gecko for Mozilla family (FF, SeaMonkey, etc).

    * Apple for Safari is the same as for profit Mozilla Corporation for Firefox browser -- marketing.

    * quirks (not part of the established standards) is exactly what Trident (MSIE engine) and Gecko are using to implement in-page rich-text editing. and what webkit is not mimicking enough (I can see the only one major blocker open ticket in their bugzilla submitted by the Moxiecode Systems AB).

    * here’s browser breakdown from 115 million visits to WordPress.com:

    1. 62.46% - Internet Explorer
    2. 30.74% - Firefox
    3. 3.83% - Safari
    4. 1.78% - Opera
    5. 0.52% - Mozilla

    * I'm not a fan of Safari.

    .
    just think for yourself, think different ;-)

  17. sorry, unfortunately bbPress does not have a mere notion about threaded replies.

    so the post above was supposed to be a reply to Mark's statement:

    > When Apple decide to not have such a wild variety of browsers then Tinymce - who code our editor - can probably start addressing any quirks.

  18. my profile doesn't say anything about rich text format ... i've been going through every tab in my account and can't find anything like that! i joined wordpress last March and got the Mac 2 weeks ago. I believe it's Tiger - I tried to install Leopard and only got that famous blue screen of death so I scrapped it ...

    yes, line/paragraph breaks.

    thanks so much for your help, folks ...

  19. > my profile doesn't say anything about rich text format ... i've been going through every tab in my account and can't find anything like that!

    for some strange reasons it should be somewhere at: http://ieatmypigeon.wordpress.com/wp-admin/profile.php

  20. -> Dashboard -> Users -> Your Profile
    On the right hand side of the page find the checkbox for:
    --- Use the visual rich editor when writing
    and uncheck it. Then click "Update Profile".

    And, If you cannot see this option on that Your Profile page then the solution is to use a browser that works with wordpress.

  21. @ieatmypigeon
    Here's the scoop without all the political commentary and BS:
    Safari 2 and 3 will strip out the extra paragraph breaks between paragraphs with the rich text editor active. It's on the page timethief references on the upper right under "Personal Options". Uncheck the check mark to the left of "Use the visual rich editor when writing" and then click update profile

    Regardless of whether all browsers in the world, now, or in the future, or in some alternate reality use the same "webkit" Safari has problems with the TinyMCE editor in rich text mode.

    My suggestion to get away from the problems is to download Firefox or Camino, which work with the visual rich text editor. Firefox only works with 10.3.9 or later, so if you are using an earlier version of the OS, download Camino.

  22. I'd still put it in the way you did it some posts above:

    TinyMCE (Visual) editor has problems with the Safari.

    TinyMCE claims it supports Safari partially (as I get them), but its support is not complete yet.

    also, I can't get TinyMCE editor working in the non 'rich text' mode even (whatdothemcallit 'Code'?) in the Opera. fwiw, Opera works fine with other RTE.

    anyway, all the JS driven RTE are plainly suck. all of 'em, TMCE is not an exclusion -- see http://wordpress.org/extend/ideas/topic.php?id=55 because they will never never be able to provide a x-browser compatibility.

    WP (and other "coomunity owned" CMS) users gotta wait for *free* RTE either made on Adobe Flash or, for nothing better, as Java applet. period.

  23. i'm using Internet Explorer and it's impossible to make Word Press use line breaks, nothing i try works. i use code and it prints the code as part of the text. Useless, user-unfriendly, buggy, crap system.

  24. I've been having the same problem. I use Safari and when I publish or edit a post, all the line breaks disappear and my entire post appears as one enormous paragraph.

    I've turned off the editor and am also going to try writing my next post with Firefox or Netscape.

    One other thing for the Safari folks. If you write in the 'code' tab instead of the visual editor tab and put the breaks in, it will publish correctly. The only problem with that is... if you go to edit the post, you'll have to go back into code again and separate out all your paragraphs again. It's truly annoying.

    Mike

    badnewscubs.wordpress.com

  25. When you enter code, it has to be done in "code" view, not in the visual rich text editor, or it will appear just as standard text. Are either of you using Safari? All versions of Safari do not play nicely with wordpress and the TinyMCE editor.

    My suggestion to make your blogging experience smooth is to download Firefox and use it for working on your blog.

  26. I am also on a Mac OS X Tiger 10.4.11 using Safari 3.0.4 and I'm having the same problem.
    When I go into code mode and manually enter <br> the breaks show.
    Any hints as to when this problem will be resolved as it can be quite annoying, especially since the <br> in code is removed when I go to edit a post.

    Any help would be welcome.

    Thanks,
    - France Hopper

  27. thesacredpath
    Staff

    That's up to TinyMCE, the people who write the editor used here. They have only gone from "experimental" to "partial in a year, so I wouldn't look for it too soon. As I said,

    My suggestion to make your blogging experience smooth is to download Firefox and use it for working on your blog.

  28. I've posted this in another thread recently, but for Mac users I would heartily recommend Flock as your browser of choice. Its built-in blog editor will publish to WordPress blogs without stripping out line breaks, etc. I'm now using it all the time and it's a doddle!

  29. thesacredpath
    Staff

    @wolfieb
    Thanks for posting that. I've intended to download Flock and play with it some but haven't had the time. I'm glad it's working for you and it gives Mac users another option until TinyMCE becomes compatible.

  30. I am using V2.3.1.

    I had a similar problem trying post html in a pre tag. It all ended up on one line.

    I determined the problem was when the post was output on the blog and not in the HTML editor.

    There is a function called clean_pre in: /wp-includes/formatting.php that replaces all br tags.

    So I changed:
    $text = str_replace('
    ', '', $text);
    $text = str_replace('<p>', "\n", $text);
    $text = str_replace('</p>', '', $text);

    To:
    //$text = str_replace('
    ', '', $text);
    //$text = str_replace('<p>', "\n", $text);
    //$text = str_replace('</p>', '', $text);

    And now I can have as many br tags as I want.

Topic Closed

This topic has been closed to new replies.

About this Topic