Need help? Check out our Support site, then


Infinite scroll problems with Contempt theme (and custom CSS)

  1. At http://gullmars.se I am running the Contempt theme with custom CSS to display a slightly wider page than the standard theme and slightly tweaked image frames.

    Since the Infinite Scroll feature was added to my blog I've had several problems:

    With Infinite Scroll setting on: The only way to see all my posts is to set the "Blog pages show at most" setting to an absurd number like 1000. If I set it to a more normal number I only get the ajax loading to work a couple of times and then it looks like my blog history ends after some 20 posts. This behaviour occurs in both IE9 and Chrome 19.

    With Infinite Scroll setting off: The "load more posts" button doesn't appear more than a couple of times in Chrome. In IE9 however the "load more posts" button shows up as intended.

    Also some of my two column galleries show up as one column galleries when they are loaded through the ajax loading function (even those that were already on screen displayed correctly before the load). This happens both in IE9 and Chrome.

    Could my custom CSS be interfering with the gallery columns? Before the infinite scroll feature was added I never saw problems like these.

    I've cleared my cache(s) and cookies and tried the site on a couple of different computers. In Chrome I've also tried without any extensions (adblock, keep optouts etc) loaded, but no change.

    Hope you can help!
    Blog url: http://gullmars.wordpress.com/

  2. I only get the ajax loading to work a couple of times and then it looks like my blog history ends after some 20 posts. This behaviour occurs in both IE9 and Chrome 19.

    I tested in IE9 and Chrome 19 and I was unable to reproduce this problem. I was able to scroll all the way back to the "Stenar och rötter" post without any trouble. I did need to wait between scrolling times for some of the scrolls because there are so many large images in your posts. Maybe you just tried scrolling too quickly without letting the images load.

    With Infinite Scroll setting off: The "load more posts" button doesn't appear more than a couple of times in Chrome. In IE9 however the "load more posts" button shows up as intended.

    I setup a test blog using Contempt and tried the "Load more posts" button in Chrome 19, and it always appeared in my tests.

    Also some of my two column galleries show up as one column galleries when they are loaded through the ajax loading function (even those that were already on screen displayed correctly before the load).

    I can reproduce this one, but only while testing on your blog. When I tried to reproduce the problem on my test blog, two-column galleries always worked for me. I'm not sure what's causing it yet—but your custom CSS looks okay to me. I'll do some additional testing.

  3. Many thanks for looking into this!

    I tried again and can reproduce the problem every time (on my win7 64 machine):

    1) Infinite Scrolling set to "On"
    2) cleared cache (and checked that chrome://cache/ was empty)
    3) let all images load before scrolling to the end

    Every time I end up after the post "Tömt kameran" with no further scrolling and no ajax spinner shown. This is what it looks like in Chrome: http://gullmars.files.wordpress.com/2012/06/dhdump-0183.jpg

    The same behaviour is displayed in "incognito" mode. In IE9 it flows ok (except for the two column problem).

  4. I re-tested in Chrome 19 on Win7. I have no trouble loading infinite scrolling. Example: http://cl.ly/Hf9v

    Clearing cache is a good first troubleshooting step, and I see you already tried that. I'm not sure what else to test for that report. I have nothing to go on if I can't reproduce the issue. If anyone else can test the same conditions or if anyone else reports the same problem, that would help. Does infinite scrolling work for you on other WordPress.com blogs?

  5. Since you have the upgrade, you can disable infinite scrolling for good and restore the original previous/next navigation links (if that's what you'd prefer).

  6. Does infinite scrolling work for you on other WordPress.com blogs?

    I checked a couple of other wordpress.com blogs that have infinite scrolling on, and my chrome browser fails to display them properly as well. I get one ajax load and no more. To read beyond the second "page" I have to click the permalink for the last post and use "previous post" from there.

    I will try different settings on my setup (temporarily disabling Outpost firewall and Avira free antivirus among other possible culprits) and see if I can find the problem.

    justpi >> since the problem seems to be related to viewing wordpress.com blogs with infinite scrolling on my computer, I'm happy to keep the setting. But it would be nice to find out why the ajax script fails to run/load more than once, and if it is a wider problem or just affects my windows installation.

  7. The gallery issue should be fixed now. Thanks for reporting it.

    Regarding the other issue where you are unable to read past the 2nd set of infinite scrolling posts, such as "Tömt kameran" on the http://gullmars.se/ blog, I still need additional information or reports from other people experiencing the problem since I'm unable to reproduce that in testing on two separate computers.

    Here are the steps I used to try to reproduce the issue:

    1. Go to http://gullmars.se/ using Chrome 19
    2. Scroll down until you see the "Tömt kameran" post
    3. Check to see whether you can load posts after "Tömt kameran"
    * Expected result: posts continue loading after "Tömt kameran"

  8. Thanks,

    I found the problem, after some exclusion testing. I have an extension installed in Chrome called Disconnect, to stop third party tracking. https://chrome.google.com/webstore/search/disconnect?hl=sv

    Apparently this extension is active even when running Chrome in Incognito mode, so I had to uninstall it. I've reported the problem to the Disconnect developers: https://getsatisfaction.com/disconnect/topics/disconnect_prevents_wordpress_coms_infinite_scroll_feature

    I no longer have the two-column gallery problem either.

    Happiness restored - thanks, designsimply!

  9. Back at ya! Thanks so much for reporting back with an update and solution. That's very helpful!

    I just have to say… WordPress.com has such awesome users!!

Topic Closed

This topic has been closed to new replies.

About this Topic