Need help? Check out our Support site, then


Infinite scrolling turned on by itself? How do I turn it off?

  1. Hi there!

    I was checking my blog, and discovered that infinite scrolling has somehow been turned on.

    As it was not on yesterday, and I have not adjusted any of my settings in the last 48 hours, I don't know how this happened.

    More importantly, how do I change it back? I'm not a fan of infinite scrolling, although I can appreciate how many people enjoy this feature.

    Best wishes,

    Courtenay Bluebird

    The blog I need help with is bluebirdblvd.net.

  2. Staff have been introducing “infinite scroll" to themes — a site wide change. http://en.forums.wordpress.com/topic/to-infinity?replies=137 See here for Disabling Infinite Scroll on your WordPress.com Blog http://onecoolsitebloggingtips.com/2012/03/16/disabling-infinite-scroll-on-your-wordpress-com-blog/

  3. The WP version of "disabling" the feature (when you use footer widgets) simply changes it from loading automatically to loading via the "Load More Posts" tab. You can't disable that without the Custom Design upgrade.

  4. Okay—

    Before I even caught your message, I double-checked my settings. This is really curious!

    Because I have a footer, I should not have infinite scroll on at all— and I did know that a footer cancels out infinite scroll.

    I checked Appearance> Reader> Infinite Scroll, and I found this right before I checked this thread and found your message:

    We've disabled this option for you since you have footer widgets in Appearance → Widgets.

    Yet, infinite scroll is on right now.

    The only change I made last week was shortening the number of posts that appeared per page.

    I really do appreciate all of your help.

  5. Well, I've already replied: what WP tries to pass as disabling is not real disabling.

  6. I appreciate your input very much! Unfortunately, I am really hoping that there is an alternate solution/reason to what you are suggesting.

  7. Oh my gosh, Panos! You're the amazing guy who helped me figure out the great Grooveshark mystery! Sorry, I didn't realize it was you! Otherwise I would have said, "Hey!"

    So, "Hey!" *Waves hand*

    Okay, additional specs—

      I do have one custom footer widget.

      I have a footer, anyway.

      And my dashboard is telling me that infinite scrolling is disabled because:

      We've disabled this option for you since you have footer widgets in Appearance → Widgets.

    So, it's on and it shouldn't be on, according to my dashboard. That's why it's so odd.

    I'm not sure yet what you mean by "not really disabled," but I noticed you've posted on this subject recently on your blog.

  8. As this seems to be a technical glitch, I have gone ahead and contacted WP Support.

    When I find out what happened, I will follow up to let y'all know why my dashboard reads "no" on infinite scrolling (because I have footers), and my page, magically, is scrolling, which is not my favorite thing.

    I really appreciate all of your help, and my one prior experience with WordPress support was so stellar, I am sure that this will be quickly resolved.

  9. sensuousinkspiller
    Member

    It's not a technical glitch (unfortunately) - as justpi wrote above, infinite scroll isn't truly disabled.

    If you have footer widgets, rather than it automatically continually loading additional posts on and on and on, it happens manually, and you click on the "Load more posts" button, and then it loads the next group of posts. It doesn't revert to the way it used to be, with the "previous posts" links, etc. They all still end up on the one same page. What they call "disabled" on the dashboard settings is actually making it manual, rather than automatic.

    The only way to really disable it, is with the CSS upgrade.

  10. I posted a similar question earlier today (*) and thanks to both justpi and timethief have established that it's not possible to disable the "infinite" scroll.

    Okay, I can live with that, the "load more posts" feature is not such a big deal for me -- but -- the problem that I have (using the Manifest theme on my Blog) is that this feature does not scroll or load to "infinity" as claimed ... rather, it stops completely after just one load.

    Bug, or by design?

    (*) http://en.forums.wordpress.com/topic/infinity-beyond-issue-in-manifest-theme

  11. @bluebirdblvd: No, there's no alternative solution, because WP doesn't want to make the feature optional, and WP is stubborn.

    @patrickobrien: Bug.

  12. @patrickobrien: Bug.

    Thank you very much for your help, justpi ... I'll take this up with Support.

    Cheers!

  13. Okay, I've come back from errands, and as to be expected (yay!), WordPress support had answers. And so did you!

    Yes, this is a new feature on my particular Theme, Chunk. No, you can't completely turn it off. Basically, everything you all said above is true. (Panos! Now I understand what you trying to say!)

    Now what's this about a glitch/bug in the demi/semi-infinite scroll? You only made one click?

    I made three or four earlier, and my version on Chunk is working fine for the moment. I am so sorry to hear this is happening on your blog! I hope this glitch is resolved quickly.

    Thank you @TimeThief @justpl (Panos); @SensuousSinkSpiller; and @PatrickOBrian for weighing in with such useful information!

    Best wishes— Courtenay Bluebird.

  14. 1) The bug Patrick is experiencing is browser related.
    2) The answer WP gave you is inaccurate: as I already pointed out, you can "completely turn it off" if you have the Custom Design upgrade (but WP doesn't reveal this because they don't want you to turn the feature off).

  15. 1) The bug Patrick is experiencing is browser related.

    You were quite right, justpi -- in this case the Browser add-on "Ghostery" which I resolved by adding WP to its whitelist.

    Thank you very much . . .

  16. You're welcome, although I don't really deserve your thanks - I only helped indirectly...

  17. Very disappointing…

Topic Closed

This topic has been closed to new replies.

About this Topic