Need help? Check out our Support site, then


"Infinity & Beyond" - issue in Manifest theme

  1. Greetings

    I have an issue with the new "Infinity & Beyond" feature on my Blog which uses the Manifest theme, here:

    https://patrickobrien.wordpress.com/

    Can some one please help me?

    I had originally set up this Blog to show 31 posts (a month of daily postings) on the Home page.

    Prior the introduction of this new scrolling feature, readers could load another month of posts via a clickable "older posts" Link at the bottom of the Home page and, should they wish, could continue navigating back in such fashion to the very beginning.

    Now, readers are presented with a "Load more Posts" Link which, when clicked, loads the next 31 posts -- and then stops -- with no more posts, no "beyond" and no "infinity".

    I cannot disable the feature (the obvious solution) because it is already disabled by default due to my use of a widget in the footer. Here's the message that appears in my Dashboard > Reading > Settings:

    To infinity and beyond: We've disabled this option for you since you have footer widgets in Appearance --> Widgets.

    I wish to keep the widget as it provides rel="author" functionality on Google-Plus.

    The following is very informative, yet it does not address my issue:

    http://en.blog.wordpress.com/2012/06/12/to-infinity-and-beyond/

    Thank you for any assistance

    Patrick

    The blog I need help with is patrickobrien.wordpress.com.

  2. What WP tries to pass as "disabling" isn't disabling: it's infinite scrolling alright, just with clicks instead of automatically. You cannot really disable the feature without the Custom Design upgrade.

  3. Thank you justpi!

    Update:

    I have tested my issue on three Browsers (after clearing their caches) and the problem persists on both Firefox and Chrome -- yet not on IE where I'm able to proceed past the first two pages and "beyond" . . .

  4. WordPress member justpi has an interesting post on how to disable Infinite Scrolling, here:

    http://wpbtips.wordpress.com/2012/06/05/disabling-infinite-scrolling/

    Unfortunately in my case, the relevant work-around does not work -- whether I have a widget in the footer or not, and irrespective of whether of not I have the feature enabled or disabled in my dashboard settings.

    So . . . as it appears to stand at the moment, readers are only able to access a limited number of posts from my Home page.

    Is this by design?

  5. Thank you, timethief -- most helpful as usual!

    I will play around and report back . . .

    :)

  6. The relevant workaround (i.e. adding footer widgets) doesn't really disable the feature: it simply changes it from loading automatically to loading via the "Load More Posts" tab. As I pointed out above, you can't disable that without the Custom Design upgrade.

  7. Thank you for that clarifcation, justpi

    After experimenting with both yours and timethief's work-around, I arrived at that realisation.

    Unfortunately (and worse!) irrespective of what configuration of widgets and settings I use, posts don't load "automatically" and the "Load More Posts" tab only loads once -- then nothing, effectively breaking pageination or the ability to scroll through my Blog.

    Might this just be an issue with the Manifest theme?

    If this is an issue Site wide, am I forced to pay for an upgrade so that visitors can read my Blog? ... surely not ... please tell me that's not the case.

  8. ~~justpi
    Sorry, I was out lunch. Now I've got it.

  9. Am having the same problem with the scrolling or the "load more posts" not working on the Digg 3 Column theme. It just stops and doesn't load more blog posts in either setting.

    Hope this gets fixed soon.

  10. Greetings dandelionsalad

    I have resolved my issue following a suggestion from *justpi* that it was browser related -- it was, in my case the browser add-on "Ghostery"

    I resolved the matter by adding WordPress to its "whitelist" (which raises another set of questions which I need not address here).

    Do you have any security software running that blocks trackers?

  11. Hi Patrick,

    Thanks for responding so quickly.

    I am using Firefox and Ad Blocker and Do Not Track Plus.

  12. I disabled Ad Blocker for WordPress.com but it didn't help. The number of posts stops after 10 and there is no "load more pages" button.

  13. o-kay ... then your "Do not Track" add-on is possibly your problem -- and, if so, it will also be a problem for any of your/our readers who use such or similar defences.

    Hmmm

  14. Thanks again for your help, Patrick.

    I did change the number of posts per page on the Reading setting to a much higher number (15), so now the "load more posts" button shows up once and shows an additional 15 posts. But it stops then and there is no way to see any posts after that.

    I was also wondering about the settings my readers have on their computers/browsers, and even if I can get it to work properly on my computer, what about the readers' computers?

  15. @Dandelionsalad ... have you tested to see whether or not "Do Not Track Plus" (DNT+) is causing your problem? Here's their FAQ on how to disable blocking on any particular Website:

    http://www.donottrackplus.com/faqs.php#q4

    Of course -- as I pointed out earlier and you quite correctly ask -- while I have resolved my particular issue (which was caused by Ghostery) a reasonable presumption might be made that readers using this or similar privacy protection tools will be unable to scroll back through our Blogs.

    If that were the case, I would be left with a sense of unease about the development of this "feature" and its intended purpose.

  16. Thank you once again, Patrick.

    It worked! Yeah!

    Now, I'll change the number of posts per page back to 5 so it doesn't take so long to load.

    I agree with you about our readers not being able to use the function properly while visiting our blogs. I hardly ever use the home page to look for posts, but I know visitors do.

  17. You're most welcome, dandelionsalad -- although thanks must go to justpi who, in a related thread, told me the issue was browser related and pointed me in the right direction to find the "solution".

    What remains to now be done is configure some way of informing our affected readers about this "issue" and provide them some sort of work-around, the sort of which will depend on what Theme we are using and the features it offers.

    Meantime, and to that end, I have rigged up a library Page on my header menu (Manifest Theme) -- thus:

    http://patrickobrien.wordpress.com/library/

    I will now mark this thread as "resolved" . . .

    :)

    Cheers!

  18. Thanks, Patrick and justpi, too.

    Cheers!

  19. Great idea on the "library" post listing all your posts.

    I use the "Recent Posts" widget and also have a tag/category I use on all my posts.

    Can't do the library listing as I have over 18,400 posts.

  20. . . . thank you, dandelionsalad:

    My "library" is a somewhat clumsy solution. Readers may also navigate as before via TAGS and/or CATEGORIES, I've now discovered.

    To assist my affected readers with these changes, I published the following post which summarises this and other related threads on the matter:

    http://patrickobrien.wordpress.com/2012/06/28/infinity-and-beyond/

    My post also contains links to some useful articles by justpi and timethief.

    You have over 18,400 posts?! . . . I'm just a babe among giants

    :)

Topic Closed

This topic has been closed to new replies.

About this Topic