Need help? Check out our Support site, then


insert media button

  1. I have been working to upload 2 jpg photos to my blog for the past hour. I realized that they were too big and scaled one down and it still does not work. When I click on the Insert Media button on the formatting blog view, it does nothing at all. When I choose Library from the media in the sidebar, I find the photo and it shows as if it has been uploaded to the blog, but it has not. What is wrong? Please help.

    The blog I need help with is dramawife.wordpress.com.

  2. Have you tried this?

    While editing the post you'd like to add the image to, click on the Add Media button.

    Next, choose the "Media Library" tab rather than the "Upload Files" tab.

    From here, there should be a dropdown with several options, including "All media items" and "Uploaded to this post".

    Make sure that you have selected "All media items".

    From there you should be able to see your image, select it, and click the "Insert into post" button in the bottom right hand corner.

    Please let me know if selecting "All media items" doesn't fix the issue!

Topic Closed

This topic has been closed to new replies.

About this Topic