Need help? Check out our Support site, then


Invalid activation key. Weblog already exists.

  1. We signed up for a blog and received the activation key by email, but it
    does not work. Instead, we get an "invalid activation key" notice when
    clicking the link, and "Weblog already exists" when accessing the blog.

    We already submitted an email, but it is Sunday and did not want to wait
    a few days for an answer. And, we read other posts about there being
    some type of activation key request on the home page, but we have had
    no luck finding it.

    Any help would be greatly appreciated.

  2. You've already done what you've needed to do. (ie sent in an email to support at this domain) Podz is around and I'm sure he'll get right on it.

  3. This issue is resolved. I can't believe we got such a quick response
    from a free service, and on a Sunday! If anyone else still has this
    problem, we just sent an email including our activation link and
    blog link to support@wordpress.com We sent it from the email that we
    signed up with.

    Thanks Podz.

  4. Shhhush don't tell Blogger but we've got angel geeks who work every day of the week.

  5. I'm not a geek :)

  6. ooooooowwwwww ^^ well now hmmmmm what can I say to that, eh? So sorry. I meant it as a term of endearment. And what term would you prefer that I use in it's place [she enquired fluttering her eyelashes and sucking up big time] to the winged creature from above?

  7. Can we talk about Matt? ;)

    And I know I'm a geek.

Topic Closed

This topic has been closed to new replies.

About this Topic