Need help? Check out our Support site, then


Invalid request

  1. Invalid Request
    Blog url: http://makeupkat.wordpress.com/

  2. What is the URL starting with http:// for the blog you are referring to?

    (1) If you are trying to create a post on the WordPress.com home page here http://wordpress.com/#!/post/ then forget that please. Instead create posts only on your own dashboard here > Dashboard > Posts > All Posts > Add New
    http://NAME_OF_BLOG.wordpress.com/wp-admin/post-new.php

    (2) Are you using the secure https:// login?
    http://en.support.wordpress.com/https/ If not then try using it.

    (3) Exactly which browser and version of it are you using. If you aren’t sure click here to find out > http://whatsmyuseragent.com/

    Note: If you are using an IE9 browser in compatibility mode that makes it render as IE7 and IE7 is not supported. To disable see > http://www.sevenforums.com/tutorials/1196-internet-explorer-compatibility-view-turn-off.html

    a. Try using the browser with all extensions or add-ons disabled

    b. If applicable try updating the browser to the latest stable version http://browsehappy.com/

  3. Thank you for your response. I finally got it to go up but only through Explorer it would not work in Chrome or FF and all a currant. I have no idea why since it used to work just fine.

Topic Closed

This topic has been closed to new replies.

About this Topic