Need help? Check out our Support site, then


Invalid Request

  1. http://ingridwisell.wordpress.com/

    Nothing works. I just get invalid request.

  2. Please fix!

  3. Have you tried posting via Posts -> Add New in your Dashboard?

  4. I'm having the same issue. I get invalid request everytime I post. My browsers are Firefox and IE.

  5. Mine got problems just now :( and I´ve written a huge blog entry. After the new layout showed up, I don´t know where to save my blog as a draft anymore either. so I don´t dare to restart anything.

  6. What is the URL starting with http:// for the blog you are referring to?

    (1) If you are trying to create a post on the WordPress.com home page here http://wordpress.com/#!/post/ then forget that please. Instead create posts only on your own dashboard here > Dashboard > Posts > All Posts > Add New
    http://NAME_OF_BLOG.wordpress.com/wp-admin/post-new.php

    (2) Are you using the secure https:// login?
    http://en.support.wordpress.com/https/ If not then try using it.

    (3) Exactly which browser and version of it are you using. If you aren’t sure click here to find out > http://whatsmyuseragent.com/

    Note: If you are using an IE9 browser in compatibility mode that makes it render as IE7 and IE7 is not supported. To disable see > http://www.sevenforums.com/tutorials/1196-internet-explorer-compatibility-view-turn-off.html

    a. Try using the browser with all extensions or add-ons disabled

    b. If applicable try updating the browser to the latest stable version http://browsehappy.com/

Topic Closed

This topic has been closed to new replies.

About this Topic