Need help? Check out our Support site, then


Jetpack Comments on mobile

  1. When jetpack comments is enabled, mobile users cannot make use of it. Due to the ajax / js effect that brings down the extra fields when desktop users click in the comment box. Mobile users get no such fields and thus don't even see a submit button. And since nearly half of my audience is mobile, I had to turn off the cool feature. Any chance of fixing this.
    Blog url: http://www.osazeosoba.com/

  2. bryanvillarin
    Staff

    Hi,

    I'll be happy to take a look.

    Are the Subscriptions and Mobile Theme modules in Jetpack activated, or just Subscriptions? (Are you running Jetpack 1.8.2?)

    Can you take a screenshot that displays what you're seeing in your mobile browser and paste the URL of the image here?

    Also, what mobile browser and version are you using?

  3. bryanvillarin
    Staff

    I've also run the Jetpack debugger with your site and it displays, "An unknown error has occured. Please refer to our troubleshooting guide [...]"

    Can you try the steps in the Jetpack troubleshooting guide?

  4. Hi Bryan, thank you for helping out.

    I run a responsive theme and so do not have the mobile option activated for jetpack.
    I had the commenting feature deactivated but I have activated it now. And the "xmlrpc.php" file works fine, as stated in the troubleshooting guide.

    I have used opera mini and the blackberry native browser for OS 5
    On Opera Mini, there is no option at all.
    However on the Blackberry native browser, the additional field are there while the page is loading but somehow vanish after the page fully loads. I am not sure if this is still a problem in more recent native browsers, I'll check and get back to you on that.
    But from the image I'm attaching here, most of my mobile viewers use Opera mini so it still affects their commenting capability.

    Mobile Browser stats - http://www.osazeosoba.com/wp-content/uploads/2012/10/Capture.png

    Opera Mini View - http://www.osazeosoba.com/wp-content/uploads/2012/10/Screen_20121005_212623.jpg

    Native browser before full load - http://www.osazeosoba.com/wp-content/uploads/2012/10/Screen_20121005_220451.jpg

    Native browser after load - http://www.osazeosoba.com/wp-content/uploads/2012/10/Screen_20121005_22094.jpg

    Thanks again for your help.

  5. Blackberry OS 5 is a bit out of date, and it doesn't look like they're properly rendering the javascript.

    Are you able to upgrade?

  6. Yes, I am. I guessed that was the problem with the native browser. But what about opera mini? Any chance for that?

  7. Which version of Opera Mini are you running?

  8. Version 7.0

  9. That is definitely the latest version. Do you have javascript enabled?

    Also, do you see the same problem if you temporarily switch to the Twenty Eleven theme?

  10. Javascript seems to be enabled by default on opera mini.

    I tried switching to the twenty eleven theme and still had the same issue. I also activated the mobile option for jetpack but it still won't give.
    Although I found a pretty funny trick. If you click the reply button on a comment the page reloads with the fields visible. However if you refresh the page it goes away. So you somehow have to reload the page without refreshing it. But I guess this isn't usable in live situations since you could have mobile users posting the first comment.

    I'm resetting the theme to my default now.

  11. Ok, one more test.

    Do you see the comment form correctly at http://ma.tt/2012/09/future-of-work/#comments or is it the same problem?

  12. It is the same problem. Even when I click the reply link. Still no show. :( is that bad?

  13. Ok, we're looking into this.

    Sorry for the trouble!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.