Need help? Check out our Support site, then


K2 The Blog Tab is inactive

  1. Hi
    I am building this new blog with a k2 layout :
    http://daniel97135.wordpress.com/
    And the blog tab is not functionning.
    It contains two hidden posts and one "test" regular post.
    Any idea on how I can solve this?
    I've looked all over, and sorry if I missed the answer somewhere. Thanks for the help

  2. The built-in "Blog" tab (or "Home" or "Front page", depending on the theme) is designed to take you to your home/front page (the one you get to with the link you gave above). Your "Blog" tab DOES work, but since you've set "Accueil" as your front page, it takes you to that page, not to your posts.

    If you need a tab for your posts, you must create a new BLANK page, title it "Posts" or whatever you see fit, and set it as your posts page (in Settings > Reading).

  3. I have two questions about the same k2 theme and was not able to find them in the FAQ (although maybe I was not searching well). First of all, the tab that says "blog" I would love to change to say something else. Is that possible? The other thing is, I changed my header, but when you first land on the site, you see the blue before it goes over to my site. Is there any way of avoiding that?

    Thanks for your time :) you can see what I'm talking about at my site.

    http://www.sarahespencer.wordpress.com

  4. I think the blue is theme related and you can't change it. Maybe with CSS upgrade?
    If there is a way to change the name, I'd like to know as well! Mine says, "Home"

  5. The name on the tab is hard-coded into the theme and cannot be changed.

  6. Thanks vivianpaige,
    I sort of knew that, but hoped there might be a work-around. "Home" is so generic.

  7. Funny - I added a home tab to my blog. I guess it's all in what you're used to.

  8. Right. "Home" is good. (where the heart is…) And giving it "cute" names can confuse readers. Some of the blogs (other platforms) I read regularly have recently have gotten "cute" and it's difficult to figure out where I am. Probably a good thing, not getting too cute.
    It's surprising that many blog readers don't think to click the title of the blog to get back to the home page, so it makes sense for you.
    For the original poster, though, having "Blog" as the title of a static page doesn't really make sense.

  9. Yeah, I guess I just wanted it to say "read me" or something like that, but apparently there is no way to change it from "Blog". Thanks for the help everyone.

  10. Hi Again
    Sorry I was away for a while, and thanks for your help.
    So I followed your instructions, created a blank "postings" page and you'll see that it did not work.
    http://daniel97135.wordpress.com/ the "blog" tab is still there, when you click on it, you get to the home page, and when you click on the "postings" tab (I'm leaving this as is for the moment), you get the blog page and both tabs ("blog" and "postings") are highlighted.

    I did some more research, found this link:
    http://faq.wordpress.com/2007/07/01/i-have-2-home-page-links/
    but that "parent page" trick did not work either.
    Then, for the sake of certainty, I looked on the wordpress.org (even though it's not relevant to wordpress.com) and found that developers have the same issue.

    For the moment, it seems that K2's blog page has to be the default home page and that it does not accept the Settings > Reading : front page displays a static page.

    Do you guys have a turnaround for this? thanks in advance!

  11. I'm afraid I don't understand your questions. At the moment your "Blog" tab DOES work, and DOES take you to a static page ("Accueil"); "Postings" also DOES work, taking you to your main posts area. And yes, to remove "Accueil" from the header tabs you must make it a child to another page, which should also work (there's nothing special about k2): you go to Manage>Pages, click "Accueil", scroll down to "Page Parent", select a page, scroll back up and clik save.

  12. Thanks for your help. I'm using safari and firefox on a mac (latest versions) and I experience some strange behaviour, may be you can confirm or infirm that.
    I uploaded a couple of screenshots to show what happens
    http://picasaweb.google.com/stephanebg/CompagonSante?pli=1&gsessionid=nKeMMITwBTTKldKqsHKNKg#
    In the first shot, I clicked on "postings" and I get the two tabs highlighted
    In the second one, I click on "blog" and then "Acceuil" which means "Home page" is highlighted
    In the third shot, I changed the page organization and put "accueil" as a sub-page to postings. so the home page is gone, and when I click on either "blog" or "postings", I still get the double-highlighting.
    My goals are:
    - to have "accueil" *home" (which is a static page) as the default landing page
    - to have the blog page in the menu
    - to avoid double highlighting
    Sorry about the long description.

  13. Goals 1&2: you do.
    Goal 3: in this theme you can't.

    The problem is that "Blog" and "Accueil" are the same thing now (which is pointless). As we said before, one way is to make Accueil a child-page, so that only Blog will show. But I understand you want your home tab to say Accueil, not Blog. As we also said before, you can't do that in k2 - or any other theme with a built-in home tab. You should consider simply switching to a theme with no such tab: then Accueil will show up as your home page and Postings as your posts page, and that'll be it.

Topic Closed

This topic has been closed to new replies.

About this Topic