Need help? Check out our Support site, then


Latest post upfront

  1. priyagettingcreative
    Member

    My blog does not show latest post upfront. It keeps a post written months ago at the top while the new ones are overridden by it. I want either a control on which post should be upfront or atleast the latest post should be visible on the top. Pls help
    Blog url: http://creativwins.wordpress.com/

  2. Are you sure it's not a sticky post?

    Blogs are essentially a reverse chronological order publishing tool and you cannot change this order on a free hosted WordPress.com blog. Posts will be posted to your blog in accord with their datestamps at publication. WordPress by default shows posts in reverse chronological order (newest post on top).

    If your posts are not displaying in reverse chronological order then check your date and timezone and reset if required on this page > Settings > General

    If that's not an issue then you could have a sticky posts issue. Simply remove the sticky designation. http://en.support.wordpress.com/posts/post-visibility/#sticky-posts

  3. You seem to have many Posts set to Sticky - I gave up counting at about 10.

    As noted above unstick them

Topic Closed

This topic has been closed to new replies.

About this Topic