Need help? Check out our Support site, then


"Leave a Comment" Button Doesn't Appear

  1. sbhsenglishteacher
    Member

    I have a blog for my students, and I would like them to comment occasionally. Unfortunately, the "leave a comment" button is not showing up on my blog. I have the comments enabled and I am using the "Twenty Ten" template.

    Any suggestions are appreciated!
    Blog url: http://quigleyducko.wordpress.com/

  2. Comments on all pages and posts on every WordPress blog are enabled by default. This page > Settings > Discussion
    Discussion settings is where you set up defaults for comments.
    http://en.support.wordpress.com/settings/discussion-settings/

    We can also override the default settings and enable or disable future comments on any individual post or page.
    http://en.support.wordpress.com/enable-disable-comments/

    Note: By default, new blogs on WordPress.com will have the Discussion hidden. You can reveal it by clicking on Screen Options http://en.support.wordpress.com/screen-options/ on the top right corner of your Admin page, and checking the box that says Discussion so the module is included. http://en.support.wordpress.com/modules/#list-of-modules

  3. sbhsenglishteacher
    Member

    The settings are enabled to allow for comments, but they are still not showing up on the blog. If you visit my blog, you will see there is no way for you to comment.

  4. Hi,

    On your latest post, the 'Leave a comment' link is there.

    Since you published the other posts before you enabled commenting, they don't yet have the 'Leave a comment' link. You'll need to follow timethief's suggestion, and use the instructions here to enable comments on those posts.

Topic Closed

This topic has been closed to new replies.

About this Topic