Need help? Check out our Support site, then


Likes not appearing

  1. katiefguernsey
    Member

    Hi there

    I am using the Superhero theme, and whilst I am getting notified of likes, they don't appear on the posts. Ive tried looking in the Dashboard settings and it simply won't work. The screen options doesn't give me an option like the support doc says it will.

    What am I doing wrong, or do I need to change the theme?

    Thanks in advance!

    The blog I need help with is idreamedofafrica.wordpress.com.

  2. Are you the logged in Admin of the blog?
    http://en.support.wordpress.com/user-roles/
    If so have you followed this guide?
    http://en.support.wordpress.com/likes/#likes-and-your-site

  3. smallestforest
    Member

    Hello, I'm having a similar problem, and can't figure out where on this forum to add it, so forgive me if I'm writing it here (happy to move my question elsewhere if you tell me where to go!) :

    The grid of gravatar thumbnails ("Like this") won't load on my home page, though usually does on individual post pages. This wouldn't really be a problem except that the home page never stops flickering, as though trying to load and re-load something endlessly.

    Again, if it was just my problem, I wouldn't mind, but today I got an e-mail from a subscriber who tells me: "there seems to be a crippling jitter on your main page...i originally visited your wordpress page from my computer and it was impossible to view; i just pulled up your blog from my (android) phone, and it was doing it here, too. seems like maybe there's a haywire script that's telling the page to reload 5 times a second, or something like that.. =( i was using chrome."

    So, no idea if it related to the non-appearance of the "Likes" grid of gravatars, but that's the only thing out of the ordinary with my home page.
    The blog I need help with is http://smallestforest.net

  4. @smallestforest - we're working on fixing this bug that's causing the "jitters" you reported. There is a conflict between quote and status post type formats and the Likes widget.

    To fix this temporarily while we work on this, you can edit your post titled "I CONSIDER ALL…" and uncheck the box for "show likes". Alternatively, you can disable likes on your posts page (which would retain the likes box on your posts) by going to Settings ->Sharing and turning off likes for "Front Page, Archive Pages, and Search Results" temporarily.

    We are aware of the problem and we are working on fixing it. Thank you!

  5. @katiefguernsey - Currently, you have likes enabled on a per-post basis. You can change this to show likes on all posts by going to Settings -> Sharing and clicking "On for all posts" for "WordPress.com Likes are" option at the bottom of the page.

    However, if people are following you in the WordPress.com Reader, they can like your posts whether or not likes are enabled per-post on your site.

    I hope that clarifies things!

  6. There is a conflict between quote and status post type formats and the Likes widget.

    No, it's a more general problem.

  7. Ok, I might have missed something here. Is there something making this "a more general problem" than what we've identified as the cause and are currently fixing? If there's a larger issue here than what we're about to fix, I would love to have our team take a shot at it at the same time.

  8. Thanks. I replied in the other thread: I saw the bug on static pages as well. But perhaps fixing it the way you're fixing it will take care of that too.

  9. I just saw your note in the other thread - thank you! I was not able to recreate the problem on static pages, but I will pass along that information to the team while they work on this fix.

    Thanks again!

  10. You're welcome. I remember I saw it on static pages on Hemingway yesterday, but at the moment Hemingway is behaving - in my test blog at least.
    I visit many blogs while replying to questions here, and change themes all the time in my test blog, so I'll let you know if I see the creature again on anything other than quote or status format posts.

  11. Sounds good!

  12. Thank you for your help - I've switched that but still can't see any likes under the posts, or the gravatars like I see on other people's blogs. Not sure what I'm doing wrong? There is literally no change to the blog even though I've changed the "likes on all posts"

  13. Check csonnek's reply more carefully: if you wish to display the likes etc on the main page, you must also select the option "Show buttons on" > "Front Page, Archive Pages, and Search Results".

  14. @csonnek - Thanks very much for your time and advice! I'll look into it, now, and really it's no big deal for me, though I suppose it's something you'll want to fix, if others are having the problem...I'm just really happy that you're aware of it, I'm sure it'll all come good some time. Have a Happy Easter!

  15. Well, that worked. Magic trick! *delighted* Changed the quote to standard post, turned off likes, all quiet on the Home front, now. Thank you very much!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags