Need help? Check out our Support site, then


Limiting the width for posts

  1. I have set up a simple page selecting Wu Wei. I added a background image but the current code has the post centered and the text is displaying into the non-black portion of the image.

    I am looking for how to limit the post width to a percentage and justify it to the left. Used to be pretty handy with html but am very rusty even at that. I had previously looked into CSS and seem to recall that there are ways to make the content dynamic like this but I have no idea if this would even work on the wordpress platform.

    Any insight someone can lend.

    The blog I need help with is littleboxguitars.com.

  2. There is probably a way to do it, but I'm not sure I understand exactly what you're trying to do yet. I checked http://littleboxguitars.com/ but I just see a broken image there right now. Example: http://cl.ly/LsXx

    To fix the broken image, go to the Appearance → Header page in your blog dashboard and remove or reset the header image.

    As for moving the post on the home page to the left (getting rid of the left margin), try this out in your Appearance → Custom Design → CSS editor with the Preview button. It might be a good starting point for what I think you're describing:

    .page .page .post-title h1 {
    	padding-left: 0;
    }
    
    .page .page .post-entry {
    	width: 97%;
    }
  3. Thanks for the info. Out of frustration, I simply chose a different theme and then design approach forgoing the background image entirely.

    It would seem that much of my problems of late revolve around images. I just reloaded the header image up to my my media folder as the image vanished for some odd reason.

    I am having another issue with galleries that I'll probably need to post in another forum. The gallery images don't appear reliably. That is to say, on multiple computers with different browsers, you go to the page and it is just black. As you hover over where the images are, the tags sort of highlight. If you click the image carousel opens. I've had multiple testers run into this in addition to myself. IE, Chrome and Firefox all have the issue.

  4. It sounds like you are adding images into a post or page and then also deleting them from the media library at some point. For images to work, they must be present in the media library. Check to see if the images that appear to be broken to you are still present in the media library in your blog dashboard.

  5. No the issue I am having is not related to the images not being in the media folder. They are there and if I click on the blackened page, the carousel opens and the images are viewable. This would contradict your diagnosis. I don't know why this is happening but I've had multiple people tell me they have had this issue. I've experienced it myself.

    I have a few blogs with wordpress but I've limited my interaction with them due to constant issues. I've let them languish unused but I started this one hoping things have improved. I hoped I could eventually migrate my main pages out of Squarespace. My needs are really simple. Yet upon trying WP out again, I can't seem to make a site that works reliably. I've tried multiple themes and am still having the same sorts of design and implementation problems I did in the past. This occurs when I tried to change anything other than use stock themes as is. These are not heavy modifications. I changed from white to black, added a header and changed the main page to fixed. Still I am having issues. I paid extra to have the custom package but am afraid at this point to even do anything with it. At this point, I'm not very happy with my choice for hosting this.

  6. I don't know why this is happening but I've had multiple people tell me they have had this issue. I've experienced it myself.

    Ah, so it doesn't happen ever time? Can you provide an example link I can use to try to trigger it myself?

    Also, are you using an up-to-date browser? See http://browsehappy.com/

    I've tried multiple themes and am still having the same sorts of design and implementation problems I did in the past. This occurs when I tried to change anything other than use stock themes as is. These are not heavy modifications. I changed from white to black, added a header and changed the main page to fixed. Still I am having issues. I paid extra to have the custom package but am afraid at this point to even do anything with it. At this point, I'm not very happy with my choice for hosting this.

    Sorry to hear you're having trouble! Maybe you've happened to try some modifications that were tough to make based on your theme choice, and if that's the case, the forums are totally here to help you out. Just make a new help request for each separate issue, and we can totally work through them. What you described, such as making a main page fixed, could be super simple in one theme while it isn't in another. So I think it's worth looking at some of the customizations you want to make in more detail.

    They are there and if I click on the blackened page, the carousel opens and the images are viewable. This would contradict your diagnosis.

    Aside from CSS, the galleries issue you described don't sound right to me, but I haven't seen any other similar complaints about that posted in this forum either. I'd like to investigate it if you can provide some links for me to test out.

  7. Any of the gallery links on littleboxguitars.com such as http://littleboxguitars.com/photos/jazz/

    As to browsers, this has been an issue on multiple computers of mine. One PC is still XP but has up to date firefox and chome. My laptop is windows 7 and is running IE 9 along with firefox and chrome. I can not speak to those that have reported issues as to what they are running but I know I am up to date and have seen the issue in both chrome, firefox and IE on multiple machines.

    I had initially started site design with another theme and had bigger ambitions that included a dynamic background image. Those ideas were abandoned as I could not make them work. I then switched to another theme and as I pointed out, only made modifications within the theme options and nothing in CSS. That is to say, there are two options for color, white or black. I chose black. There was an option to add a header image. I created one in Photoshop that was the exact width and height recommended. That somehow vanished and I uploaded it again. The last option I chose was to have the main page fixed and have posts on another page. None of these choices should be giving me problems with galleries. Yet I've asked about a half dozen people to comment on the initial layout design only to get reports back that one thing or another isn't working.

    It was my hope that due to the really simple nature of some of my sites, I could migrate a few to WP from Squarespace. If these themes are so temperamental as to not be able to be backwards compatible, this experiment will just not work. I was happy to pay for the ability to customize but the feeling I am getting is that it is a waist of money. Things need to simply work. I have already made a ton of compromises from where I started to envision this to an almost bone stock configuration and I am being told that it is not enough.

    My needs are a fixed front page with a galleries heavy site, contact page and basic blogging. How do I get there?

  8. marianojmiguel
    Member

    Weird. I'm checking out the gallery link you posted and it seems to work fine. If you want to implement a contact page, you should check out http://en.support.wordpress.com/wufoo/ :)

  9. Yes, today it seems to all be fine. That hasn't quite been the case everyday.

    I had posted the original question on the best way to limit the width of the blog post to a percentage. I got that answer but replied to the comment on the missing header that mysteriously vanished. It went in its own direction from there. I have certainly let this go far off field as this is the CSS forum. I posted the temperamental galleries question in the support forum. I'll see if there are any replies forthcoming.

    I thank one and all for your input. Sorry if I seem a bit frustrated. I'll mark this as resolved.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.