Need help? Check out our Support site, then


Links on Facebook - how to get it to show the photo I want?

  1. Hello wordpressers and hopefully expert ones at that..

    We've been including a link to our blog in posts we're making on Facebook pages related to our blog. The problem is that when we post, Facebook seems to automatically grab an image from the blog to insert into the post. This would be fine if the image was our band logo, but it seems to just randomly pic a photo from any of the media that is on our blog. Since these photos could be anything, it can seem weird when the photo it inserts doesn't suit the context.

    Ideally, we'd like to be able to have it so that any time we include the link to our blog, the image that is inserted is our band logo, each and every time. Since I have no idea how or why it's doing what it's doing in the first place, can't really figure out what to change on our wordpress site to make it behave as we'd like it to.

    Any help or enlightenment on this issue would be greatly appreciated!

    Also one other thing.. it also seems to insert the text: (no title) above the photo, in blue text such that it is the actual text you click on as a link to go to the blog. Why on earth wouldn't it include the actual name of our blog in blue as the link?? The blog does have a title!

    If anyone can shed any light, that would be great.

    Cheers!

    http://jumeauxmusic.wordpress.com/

    The blog I need help with is jumeauxmusic.wordpress.com.

  2. This is not a WordPress.com issue. The image that Facebook selects is entirely up to them. They use a very strict set of criteria which we have absolutely no control over. There isn’t currently a way to pick out the image manually for a WordPress.com post but you may try using a theme that supports featured images. http://en.support.wordpress.com/featured-images/
    If a featured image isn’t set or your theme doesn’t use featured images, then the code tries to pick the first image in the post or page. If no image is found, then the blavatar is used, which is one reason you may have seen a logo in some cases. http://en.support.wordpress.com/avatars/blavatars/ Try making sure the first image in the post or page is the one you want to see used.
    More here > http://en.support.wordpress.com/publicize/#troubleshooting

  3. Hey, thanks for the prompt and thorough response!

    The theme we're using is Modularity Lite. I think it uses featured images but I'm a bit of a novice (can you tell?) so, unsure about how/if I've actually selected a featured image.

    If you can give me a quick pointer on where I should look to set this up, that would be awesome. Meantime, I'll look at the links you kindly included and see if I can figure it out for myself.

    Cheers!

  4. For featured images in the Modularity Lite theme version in use here at WordPress.com see here > http://wpbtips.wordpress.com/2010/06/24/modularity-lite-100th-theme/

  5. Please let me add this about images. Every image ought to be properly sized and optimized prior to uploading. That way the cropper does not come into play and there is no loss of image quality.
    maximum displayed image width by theme
    sidebar widths by theme

  6. Thanks for the info. Will look into it!

  7. Best wishes with your blog. :)

Topic Closed

This topic has been closed to new replies.

About this Topic