Need help? Check out our Support site, then


Links/URLs of Amazon.com pages in posts make Amazon ads appear in my text. Why?

  1. New WordPress.com blog. In a sample post, I included some URLs linking to pages on Amazon.com (as part of someone's resume -- the author of books; not for shopping).

    When the post was published, the Amazon URLs somehow caused actual Amazon advertisements for those books to appear unbidden in the middle of my post!

    How the heck did that happen? I tried switching themes and the ads also appeared in other themes as well.

    I tried in vain to find some setting in the Dashboard to turn off or disable this "feature," but could find no way to do so.

    (I experimented with turning on and off something called "AdControl" under the "Settings" menu, but it had no effect.)

    What am I missing? How can the ads-within-the-post feature be disabled?

    Any help would be greatly appreciated.

  2. What is the URL of the blog? What is the URL of the specific post that is having this issue? Are you using affiliate links?

  3. I'd rather not say what the blog is. However, I'll just "solve" the problem hiding hiding the URLs, which make the ads go away. (It only happens when the URLs are just pasted in plainly -- not used in an html link.

  4. Actually, designsimply (Staff) mentioned something about this last year:

    http://en.forums.wordpress.com/topic/how-do-i-add-a-new-widget-in-my-sidebar?replies=3#post-1023413

Topic Closed

This topic has been closed to new replies.

About this Topic