Need help? Check out our Support site, then


Lots of spam getting through filter

  1. I've noticed a large amount of really obvious spam comments making it through my blog's spam filter of late. The filter has always worked exceptionally well for me, so I'm hoping that this particular glitch will soon be resolved. I know there's been a lot of changes with Word Press in recent months and am wondering if anyone else experiencing the same problem? Is there something I need to do, or some new setting that needs to be adjusted to get it back to normal? Thanks.

    The blog I need help with is showmeoz.wordpress.com.

  2. There is no normal for spam. Spammers are always trying to find new ways to get their links on our blogs. Both robotic generated and human generated spam come in waves and intervals. The vast and overwhelming majority of all so-called information on the internet is spam. Over 80% of all so-called comments submitted to .wordpress.com blogs every day are spam. The worst of all spam containing malware and viruses is not sent to us. It's removed as it could bring down many blogs if opened.

    On the spam that Akismet catches it takes only seconds to click "empty spam" and you don't even have to click "empty spam" if you don't want to. Akismet will maintain comments it has caught for 15 days from the time they were received, and then it will delete the comment automatically.

    If you get spam that slips by Akismet then mark it as spam (do not delete it) and over time Akismet will learn it's spam.

    There is no such thing as eliminating all spam but Akismet works very well. For more information please take the time to read "5 things every blogger should know about spam" on this page Akismet: How it works http://akismet.com/how/

  3. Thank you, Timethief. Askimet has worked exceptionally well for me since beginning my blog over two years ago. It just seems to me that a larger than normal number of spam comments have been slipping by the Askimet filters and landing in my inbox lately. No major concern, just curious...

  4. Hi Jill,
    You're welcome. I've seen this too. Spam comes in waves and now humans are paid to post spam the burden has become much larger. I simply adjust my discussion settings to close comments on posts older than 30 days for awhile and if that doesn't do it then I change the setting to 14 days and wait it out.

  5. Thanks again, Timethief. I'll have to give that a try. Appreciate the support.

  6. I've had this too - loads coming through over last week. Timethief, I'd like to do as you suggest and set to close comments on posts older than 30 days. Where can I change this setting on the dashboard? Many thanks!

  7. Hi, isabelashdown. Here's how you change those settings. Go to your dashboard and click on these in order - discussion - other comment settings - Automatically close comments on articles older than xx days. I decided not to change this setting as Askimet seems to be catching the stray comments from my blog again and putting them where they belong! Good luck!

  8. Perfect - many thanks Jill. I've switched it to 14 days for now as I'm getting one through every hour or so at the moment! Hopefully the spam will slowly reduce back down again ... Thanks again :)

  9. You're welcome. Best of luck!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags