Need help? Check out our Support site, then


Mac OS X version 10.8.5 Unable to create directory wp-content/uploads/2013/10

  1. Hi WordPress Community

    I’m new and I’ve seen that this is a topic that has been generally touched upon but my situation seems slightly more specific.

    I am on a Mac OS X version 10.8.5. I have successfully installed WordPress locally on my computer but I’m having trouble installing a theme.

    When I got to my WordPress dashboard and select Appearance/Themes/Install Themes/Upload and navigate to my zip theme Applications/XAMPP/xamppfiles/apps/wordpress/htdocs/wp-content/themes/CherryFramework.zip and select “Install Now” I get the following message.

    “Unable to create directory wp-content/uploads/2013/10. Is its parent directory writable by the server?”

    Not sure if you need to know this but in my web browser the path is http://localhost/wordpress/wp-admin/update.php?action=upload-theme.

    When I “get info” for the following:
    Applications folder - system is Read & Write, admin is Read & Write, everyone is Read only
    XAMPP folder - system is Read & Write, admin is Read & Write, everyone is Read only
    xamppfiles folder - system is Read & Write, admin is Read & Write, everyone is Read only
    apps folder - User Name (Me) is Read & Write, admin is Read only, everyone is Read only
    wordpress folder - User Name (Me) is Read & Write, admin is Read only, everyone is Read only
    htdocs folder - User Name (Me) is Read & Write, admin is Read only, everyone is Read only
    wp-content folder - User Name (Me) is Read & Write, admin is Read only, everyone is Read only
    themes folder - User Name (Me) is Read & Write, admin is Read & Write, everyone is Read & Write
    CherryFramework.zip - User Name (Me) is Read & Write, admin is Read & Write, everyone is Read & Write

    So to me everything looks good. What am I doing? Why am I still getting that error message. Thanks in advance for your help.

  2. Anyone have any ideas?

  3. 1) bumping threads is rude

    2) see below for why response might have been slow

    The site you are asking about does not seem to be hosted on WordPress.COM so you need to make friends over at WordPress.ORG the keepers of the software you are using.

    http://en.forums.wordpress.com/topic/7-things-to-know-before-posting-in-wordpresscom-forums?replies=1

    This site is for support of sites hosted on WordPress.COM. You should address your questions to WordPress.ORG the keepers of the software you are using: http://wordpress.org/support/

    For more on the difference: http://support.wordpress.com/com-vs-org/

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags