Need help? Check out our Support site, then


Main blog not showing up on navigation tab

  1. I should have 5 tabs on the navagation bar - 4 static pages and the blog page (called 'blog') which I update regularly.
    I can't find the blog when I'm on the landing page. The tab has disappeared from the top. I've tried setting it as a child page and then resetting as a parent page, but it hasn't made any difference.

    If I had to choose only three, I'd go for the welcome, my books and the blog.

    The blog I need help with is rhodabaxter.com.

  2. http://rhodabaxter.com/blog/ is the URL.

    The front page of the blog by default will display your posts (not pages) in reverse chronological order, with the most recently published post on top. The only way that can be changed is by setting a static front page. If you do not want all the posts to show on the front page, then you can create a static front page called for example “Welcome” for your site and a “Blog” page for posts.

    To do that create two pages > http://en.support.wordpress.com/pages/ After you do that you go to > Settings > Reading and make the designation change and click “save changes”.
    http://en.support.wordpress.com/pages/front-page/

    Front page displays
    __ Your latest posts

    A static page (select below)
    Front page:
    Posts page:

    If that's not what you mean and you are referring to Pages and you have other Pages that are not displaying I suggest you go to > Dashboard > Pages > All Pages and hover over the Page titles then click "edit" and check the page visibility settings in the Publish module.
    edit pages screen http://en.support.wordpress.com/pages/edit-pages-screen/

    Troubleshooting – My Pages aren’t appearing
    They must be public pages – not private.
    Public – The page will be visible to everyone.
    Protected – The page is protected with a password you set. Only people who have the password can view a protected page.
    Private – Pages are only visible to blog Editors and Administrators. Private pages are not visible in Reader, feeds, or in any search. A page can be private without being password protected.
    http://en.support.wordpress.com/pages/

    If you create a custom menu http://en.support.wordpress.com/menus/ then you can add Pages to it and create the order you want.
    http://en.support.wordpress.com/menus/#changing-the-order-creating-sub-menushttp://en.support.wordpress.com/menus/#adding-pages

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.