Need help? Check out our Support site, then


Make a Home Tab in Greyzed theme?

  1. Greyzed http://peregrine5700.wordpress.com

    I went to your WORD TIPS blog site and looked under Themes>Home Tab

    I see you listed GREYZED as having a header tab and a built-in Home tab, yet I look at my blog and do not see a Home tab. I went to Dashboard > Appearance > Menues to find a Home tab to include in the Custom Menue, but there is none. The email and About etc tabs where there, but no Home tab.

    Your WORD TIPS site explains how to create a Home tab (under the Header) by using some code, but then on the Page Tabs As Extra Links page, you have my theme, GREYZED as having major problems with using that code.

    Therefore, is there something else that I can do to have a Home tab in my Header? :-)

    Thanks, Panos.............

    - Peregrine

    The blog I need help with is peregrine5700.wordpress.com.

  2. Custom menu.

  3. Oh, ok....... so this means that there is no other way to get a HOME tab under the Header? Aw ratz. But thank you for the info. I will make a custom menu using the short code from Panos in his WordPress tips.

    I see that I wrote WORD TIPS my first post above. That should have been WORDPRESS TIPS. 8-(

    -Peregrine.

  4. No, I didn't say there was no way. You have to use a custom menu and then select "home" as one of the tabs you want. If it doesn't show up in the pages list at appearance > menu then click the "view all" link in the pages module and it will.

    See here, http://flippintestblog.wordpress.com/ , and you will see the home tab. I did a custom menu and selected the home tab as one of the pages I wanted to be displayed. Make sure and select the menu you create in the "theme locations" module and click save or your custom menu will not show up.

  5. To create a Home tab if you're using a custom menu, you need to use the Custom Links module.

    But if your menu includes pages only, then you don't need a custom menu at all: go to Appearance>Menus, select the blank option from the dropdown in the Theme Locations module, click Save. That way the theme will revert to its standard menu (which includes the built-in Home link).

  6. Oh! NOW I understand what you said above... in the last sentence. When I toggled to the blank dropdown, I noticed that the PAGES menu suddenly DID have a HOME tab.
    I never would have figured that out with just the brainpower that exists between my ears right now.

    So, all right, I saw the HOME tab and then I selected it and hit Add To Menu. Now I have a Home tab in the Header.

    Thank you to Richard and Panos and WordPress Tips.. This is fun. :-) :-) :-) :-)

    -Peregrine

  7. @panos, actually you don't have to use the custom links. All you have to do is click the "view all" link in the pages module at appearance > menus. A home link will then appear and all you have to do is select it like you would any other page.

  8. @tsp: Thanks - hadn't noticed that (and didn't expect it: perpetuates the confusion between static and dynamic pages).

  9. You're welcome, and I had wondered about static main pages that are named "home" as well. I haven't done any testing on that. It could be though that there will still be only one "home" listed in the pages module.

  10. A new Menu problem:

    I have to type my link here because if you click my gravatar, you will be taken to the wrong (older) blog. The correct blog is: http://peregrine5700.wordpress.com

    Well, now that you both have solved the problem of the Home tab in the header for me, can you solve another? As opposed to me making a new thread? (I'm scared to do a wrong thing with threads now.)

    The new Menus problem is this:

    I made a Pages tab. Then I nestled four different pages under that Pages tab by indenting them in the Menus page. I assume that if the template allows one to indent pages, this means that there will be a Pages drop-down menu on the Header.

    Well, but the Pages do not drop down in a menu. They show as separate tabs.

    Assuming that Greyzed has drop-down menus, what should I be doing differently to get that effect?

    -Peregrine

  11. Richard ~~ I clicked Save. :-)
    -Peregrine

  12. I don't know what you mean by indent. I have the Greyzed theme up on my test blog and "yes" child pages do display in dropdowns from parent pages.

  13. I also created a custom menu and chose to add the same parent pages and their child pages in it. The child pages are displaying as dropdowns under the parent pages just like they did before I created the custom menu.

    As I cannot duplicate the behavior you describe and the Greyzed theme is operating correctly on my test blog, perhaps your blog has a technical problem that ought to be reported to Staff. http://en.support.wordpress.com/contact/

  14. Timethief.... Since you and the others do not see any other possible way, I will send to the Support Staff. I don't like to send to them unless you guys have all decided that it is the place to go.

    Also, by indent, I meant what you said. Child pages. I will give it a shot one more time with clearing the cache, quitting Firefox, and all the rest.

    If it worked for you with Greyzed then it ought to work for me. -Peregrine

  15. Wait wait! It just occurred to me that maybe I have screwed something up on the Menu page. Here is a screenshot of my Menu page. Notice I have chosen my PEREGRINE menu.
    [caption id="attachment_24947" align="alignnone" width="614" caption="MY MENU PAGE"]<img class="size-full wp-image-24947" title="Discussion Settings ‹ THE MARXIST MUST GO! — WordPress" src="http://peregrine5700.files.wordpress.com/2010/07/discussion-settings-e280b9-the-marxist-must-go-e28094-wordpress2.jpg" alt="" width="614" height="238" />[/caption]

  16. Oh ratz. That is the wrong file. I will send the correct one next.
    8-( 8-( 8-(

    -Peregrine

  17. Ok. Here is the correct MENU PAGE on which I made all those Menu settings and still cannot get Child Pages to show on the Home Page Header in Drop Down Menu.
    -Peregrine

    <img class="alignnone size-full wp-image-24950" title="MY MENU PAGE" src="http://peregrine5700.files.wordpress.com/2010/07/my-menu-page.jpg" alt="" width="614" height="602" />

  18. Go to the "theme locations" section and select your menu name from the "primary" pulldown and then save. You haven't yet told wordpress where you want your menu applied.

  19. Everybody: I just did some checking around and looked carefully at the Edit Pages page. There is a box which I filled in, indicating what was to be a parent page or a child page. After I did that, I checked my Header, and lo and behold, there was a drop-down menu with the parents and children. Here is the screen shot:

    <img class="alignleft size-full wp-image-25007" title="Edit Page ‹ THE MARXIST MUST GO! — WordPress" src="http://peregrine5700.files.wordpress.com/2010/07/edit-page-e280b9-the-marxist-must-go-e28094-wordpress.jpg" alt="" width="614" height="377" />

  20. Richard, you wrote: Go to the "theme locations" section and select your menu name from the "primary" pulldown and then save. You haven't yet told wordpress where you want your menu applied.

    But that is what I did earlier today after being told to do it. To click to the transparent option and click Save.

    -Peregrine

  21. Aw ratz! 8-( My grandchildren pages do not show in the dropdown menu. I have Pages and then a Child: Our American Heritage. Then grandchildren: Thomas Jefferson quotes and something else.

    I clicked Save, I checked that it was in my Peregrine menu, and when I checked the Header, well, you can see what I see: No mention of the Thomas Jefferson etc pages nestled under the American Heritage page.

    *$Xx@ rats dead rats

    -Peregrine

  22. In case anyone is still reading this thread here is the true ending: I just discovered that the Grandchild tabs do indeed exist. I did not see them because I had my blog page pulled in tight and narrow. When I widened it, I saw the Grandchild tabs extending horizontally to the right. I had expected them to extend downward, vertically.

    So I am happy to have my tabs all nested with three generations of pages.
    '
    -Peregrine

  23. Great news! Issue resolved. have a good evening. :)

Topic Closed

This topic has been closed to new replies.

About this Topic