Need help? Check out our Support site, then


Managing static homepage and blog page (theme: Adelle)

  1. paolamontalbano
    Member

    Hi everybody,
    I hope I'm in the right place.

    At the moment, when you arrive on the homepage of my site you see a blog page, I mean the classic page filled with posts with the most recent one on top and so on.
    Now, I'd like to have a static page as homepage and to have the blog page somewhere else, so that you can get to this blog page clicking on a "Blog" link in the main menu.

    I saw that the WP free theme I use, Adelle, allow me to do so, but I can't understand how.

    From the Dashboard, I go to Appearance --> Customize. Then, selecting Front I can read "Front page displays:" and I can choose between "Your latest posts" and "A static page". If I select "A static page" I'm allowed to choose which page to use as Front page, and that's fine. I'm also allowed to choose which page to use as Posts page, but among the shown pages of my site there is not the page where my posts are actually published.

    I even tried to check Apperance --> Menus, but I couldn't get a solution.

    May anyone help me? I hope I explained my problem in a clear way.
    Thank you

    The blog I need help with is laciclografica.wordpress.com.

  2. By default the front page of your blog displays all published posts (not pages) in reverse chronological order, with the most recently published post on top. That is for the convenience of your returning visitors, who come to read your latest post, and who are not likely to be happy with being compelled to click through the same static page with the same blah, blah, blah on it every time they visit the blog looking for the latest post.

    However, if you do not want all the posts to show on the front page, then you can create a static front page called for example “Welcome” for your site and a “Blog” page for posts. To do that create two pages first http://en.support.wordpress.com/pages/

    After you do that you go to > Settings > Reading and make the designation change and click “save changes”.
    http://en.support.wordpress.com/pages/front-page/

  3. paolamontalbano
    Member

    Ok,
    thanks for your quick reply (so quick that I even missed it...).
    I'll try to follow your suggestions and I hope it will work.

    Thank you

Topic Closed

This topic has been closed to new replies.

About this Topic