Need help? Check out our Support site, then


max image size weirdness in under the influence theme

  1. whyohwhyohwhyoh
    Member

    i've added some images to some posts using the zemanta 'recommendations' system - that seems to work fine. the images are set to right-aligned, medium width.

    on the home page of the blog the theme uses max-width and max-height to show the images smaller. the default max-width in the theme options is (almost?) the full width of the columns on the home page so i halved that a few days ago and all seemed to be well - the pictures were smaller but had the correct proportions.

    however, since yesterday evening the image proportions have got messed up - it's as if the max-height wasn't being applied until yesterday evening.

    today i've tried adjusting the max-width and max-height settings in the theme, making the max-height larger - but the theme seems to use the max-width value (specified in the theme options) for both max-width and max-height in the css - so tall images end up squashed square.

    has something been changed? please help. :-)

    The blog I need help with is themorningbabel.wordpress.com.

  2. whyohwhyohwhyoh
    Member

    the blog address is http://themorningbabel.wordpress.com

    i've done some reading and testing around the max-width and max-height css settings and can see the the proportions of the image should be retained. so i've no idea what it is elsewhere in the css which is messing up the pictures but:

    a) it certainly wasn't doing this yesterday and
    b) the problem is appearing at least on firefox 9, IE8 and epiphany

  3. This needs to be fixed by staff. In the meantine you can correct your images one by one by modifying the code in the HTML editor. Delete the alignment command and the width and height commands, and change this:
    <img class=ETC ETC
    to this:
    <img style="float:right;width:300px;margin-left:3px;" class=ETC ETC

  4. @whyohwhyohwhyoh

    Sorry for the issue you are experiencing. We did fix a long-standing bug in Under The Influence theme in the last night. Your CSS used work well with the theme CSS which had a bug but now the bug is fixed and your CSS is now causing the disproportion issue.

    If I may suggest you, the quickest fix is that deleting max-height, and the images will retain the proportions. Then you ca adjust the value of max-width to get the right outcome.

    Please let me know if you need further assistance.

  5. @Takashi: When you set the max-width to, say, 300, the CSS of the theme imposes the same restriction to the max-height no matter what you've set for it in Theme Options:

    #three_column img.alignright, #three_column img.alignleft, #three_column .wp-caption.alignleft img, #three_column .wp-caption.alignleft, #three_column .wp-caption.alignright img, #three_column .wp-caption.alignright {
    height: auto;
    max-height: 300px !important;
    max-width: 300px !important;
    }

  6. @panaghiotisadam

    Oh, I see. I misunderstood that's done by the user's custom CSS. I'm looking into what we can do.

    @whyohwhyohwhyoh
    My apologies. We update you at here as soon as possible!

  7. @All
    A fix has been released and the theme now correctly apply the max-height value that's set in the theme options page.

    @whyohwhyohwhyoh
    I can see all your image now keep the image proportion.

    Please let us know if you need further assistance.

  8. whyohwhyohwhyoh
    Member

    @panaghiotisadam, @iamtakashi many many thanks for the quick analysis and prompt resolution - totally awesome! once again glad i recommended wordpress.com and its community to my friend. :-)

  9. @Takashi: Thanks. (Note that if the issue was with the user's custom CSS, I wouldn't have said it needs to fixed by staff and I wouldn't have given an inline CSS workaround.)

    @Whyohwhy: You're welcome!

  10. @panaghiotisadam: Thanks for your help as always!

    @whyohwhyohwhyoh: You're welcome!

  11. i experience a related problem on http://uneeqblog.wordpress.com with the "comet" theme. if i insert a picture into an article that is bigger than the layout column (600 px width), they are automatically downscaled (as desired) to fit the layout. however, this does not work on internet explorer 8, where the picture is only downscaled in width but not in height, which leads to a skewed image. why is this a browser version related problem, and how can i fix it? thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic