Need help? Check out our Support site, then


Maybe it's just me but I can't get the Category widget to work

  1. Right now I'm trying to use the Spectrum theme, which I discovered is one of many that doesn't have dropdown parent/child navigation tabs. I tried to create my first Custom Menu but I'm not having any luck. So far all I have are the main tabs...and they aren't even in the correct order, despite my efforts to organize them. I thought i would try the category widget but i'm not getting on with it, either. If I activate the Page widget, it takes all of the categories and lists them (in "child" format), making the extra Category widget seem redundant. And the Cat. widget isn't working for me anyway. ;-(

    On the whole, that sidebar option looks rather messy on this theme. I'd much rather have the dropdown tabs along the top (as I did successfully with a Twenty Ten site).

    Are there steps I'm missing somewhere in trying to work with the aforementioned functions? Or maybe it's just WP being wonky today?

    The blog I need help with is honeybunch55.wordpress.com.

  2. Sorry but I seem to have too many topics in one post, lol. If this needs to be moved, feel at liberty to do so. :)

  3. Spectrum does not have dropdown support natively, but it supports dropdown menus through the custom menu feature.

    http://en.support.wordpress.com/menus/

    Check on the custom menu page and make sure in the "theme location" module that you have chosen your custom menu in the primary location pulldown and make sure and save after setting that. If you have not done this, the custom menu is not live.

    Categories widgets will only show categories once the category is assigned to at least one published post otherwise clicking on the category name would produce a 404 file not found error since there would be no posts to show. Are all the categories you have assigned to at least one published post?

  4. Spectrum does not have dropdown support natively, but it supports dropdown menus through the custom menu feature.

    http://en.support.wordpress.com/menus/

    Check on the custom menu page and make sure in the "theme location" module that you have chosen your custom menu in the primary location pulldown and make sure and save after setting that. If you have not done this, the custom menu is not live.

    Categories widgets will only show categories once the category is assigned to at least one published post otherwise clicking on the category name would produce a 404 file not found error since there would be no posts to show. Are all the categories you have assigned to at least one published post?

    Since you did not provide a link to the blog you are talking about, I can't really look around to see if there is something out of the ordinary happening.

  5. Uhh...no...and I bet I can guess what is currently wrong, lol...I only have empty pages created--10 of them, you can see from my link--with 6 categories. I don't have any postings yet either...

    I switched off to another theme (although I might go back to Spectrum if I can get the custom menu working) and noticed the same problem with categories...but again, maybe I'm putting the cart before the horse, so to speak...

    Will get back to this project shortly and let you know what happens. :)

Topic Closed

This topic has been closed to new replies.

About this Topic