Need help? Check out our Support site, then


Menu bar displaying vertical instead of horizontal

  1. I recently went to add content to my blog, and I noticed that my menu is displaying vertical instead of horizontal. I want the horizontal menu so that people can choose the submenu pages, where now if they hover over the page, the subpages aren't clickable, because they disappear when the mouse is moved away. I've tried to research why this change happened and how to ensure a horizontal menu, and have gotten nowhere. The weird thing is, when I go to customize, the menus display correctly! Please help me figure out how to change this display.

    Thank you.

    The blog I need help with is gracesongs.wordpress.com.

  2. Your theme is operating the way it is designed to. http://sidekickdemo.wordpress.com/
    If you don't like how the menu displays Page links in Sidekick you can choose another theme. http://theme.wordpress.com/

  3. P.S. I forgot to say that I'm using Firefox 26.1 and all the sub-page links are clickable for me. None disappear.

    Please work through what follows and report back.

    1. If you are not running one of the browsers and versions listed at http://browsehappy.com/ please try upgrading or switching first.

    2. If you are using an IE browser in compatibility mode please disable that mode. http://www.sevenforums.com/tutorials/1196-internet-explorer-compatibility-view-turn-off.html

    3. If you are running one of the browsers and versions listed at http://browsehappy.com/

    (a) Try clearing your browser’s cache http://www.google.com/support/accounts/bin/answer.py?hl=en&answer=32050

    If applicable see here for instructions on how to clear the cache for Chrome and Safari on the iPad:
    http://browsers.about.com/od/howtousemobilebrowser1/ss/safari-ipad-clear-cache.htm
    http://browsers.about.com/od/howtousemobilebrowser1/ss/How-To-Clear-Browsing-Data-In-Chrome-For-Ipad_6.htm

    (b) Make sure that you have both third-party cookies enabled and JavaScript enabled
    http://en.support.wordpress.com/third-party-cookies/
    http://www.google.com/adsense/support/bin/answer.py?answer=12654

    (c) Disable all browser extensions or add-ons temporarily.

    (d) Try enabling HTTPS: http://en.support.wordpress.com/https/

    Add both *.wordpress.com and *.wp.com to your list of trusted sites under the Security tab. Make sure to uncheck the box for “Require server verification (https:) for all sites in this zone.” http://en.support.wordpress.com/https/#frequently-asked-questions

    4. Try using another browser.

    5. If you are not successful let us know:
    (a) Exactly what kind of device you are using to connect to the internet and to WordPress.com.
    (b) Exactly which browser (and version of it) you’re using by checking here if necessary http://www.whatbrowser.org/
    (c) And exactly what any error reports you receive state.

  4. Okay, that's fine, but in your example as well, you can't click on anything below the first parent link because once the mouse moves, it highlights the next parent page instead of the child page. How do you get around that?

  5. I do not have that issue.
    I am using Firefox 26.1.
    I assume you have a browser related issue.
    That is why I posted what I did above.

  6. (a) Exactly what kind of device are you using to connect to the internet and to WordPress.com?

    (b) Exactly which browser (and version of it) you’re using? Check here if necessary http://www.whatbrowser.org/

Topic Closed

This topic has been closed to new replies.

About this Topic