Need help? Check out our Support site, then


Mixfolio - Help with Gallery Thumbnails

  1. Hello, I am pretty new to this. I am using the Mixfolio theme, and inserting a gallery into each post. However, the gallery's thumbnails aren't lining up three across. Some are, but then a line has one thumbnail, or two, etc. I didn't have this problem when I tried Triton Lite, they all lined up neatly, but I'd really like to use Mixfolio.

    I have tried different sized thumbnails, different sized images, shortening the captions, rearranging the order, changing the alignment, changing the columns (I can only seem to have 3, no matter what I select). What am I missing?

    Any help would be appreciated!

    The blog I need help with is nbhollywood.wordpress.com.

  2. You can change the number of columns in a Gallery on the Gallery tab in the Image uploader, or faster, switch to the HTML view and in the gallery shortcode write
    [gallery columns="4"]

    4 being however many columns you want to have. If you've changed the number of columns and still end up three, please let us know.

    More on the Gallery here
    http://gammagirl.wordpress.com/2008/07/27/not-the-official-wordpresscom-gallery-faq/

  3. Thank you, yes I have tried this (I've tried 2 and 4 columns) and it still remained at three. I have tried changing the columns both ways, in the uploader and in HTML view.

    I don't know if it matters, but I'm using a Mac with the Safari browser.

  4. I've marked this for Staff attention; please be patient while they get back to you.

  5. Thank you, I appreciate it. I will wait to hear back.

  6. Somehow the tag for staff attention was removed and I've added it again so that someone from the Theme team can have a look.

    I've tried in my test blog and was able to change the number of columns from 3 to 4. But...

    There is also a noticeable difference (maybe bug) when displaying a Gallery when also using the Gallery post format at the same time. Using the Gallery post format, no matter what size image I've set up in the Gallery shortcode via the HTML editor (for example, medium) and no matter how many columns I've entered, in the Post itself on the "Gallery" tab, the images are always thumbnails and always in 3 columns. It's only when you move to the "Info" tab in the Post that the column/size settings are respected.

    Until we hear something back from the Theme team, try changing those posts to Standard post format and see if that doesn't suit you better for the meantime.

  7. Yes that seems to be it - when I changed my post type from gallery to standard not only did the images line up neatly but I could also change the columns. Yet if I switch back to gallery post format it has issues again.

    Thank you for your help, I appreciate it. I hope the Theme team is able to fix this when they can, I really liked the look of the gallery post format.

  8. It appears to be working properly. For example, for your post http://nbhollywood.wordpress.com/2012/07/06/postcards/ you have your gallery shortcode set as: [gallery columns = "2" size = "medium" ] and two columns are appearing.

    Keep in mind that by modifying your shortcode (or by changing the gallery settings in your media uploader), you should be able to modify how many columns your gallery will display, provided you do not exceed the number of columns allowed by the theme itself.

  9. @jackiedana-

    There is also a noticeable difference (maybe bug) when displaying a Gallery when also using the Gallery post format at the same time. Using the Gallery post format, no matter what size image I've set up in the Gallery shortcode via the HTML editor (for example, medium) and no matter how many columns I've entered, in the Post itself on the "Gallery" tab, the images are always thumbnails and always in 3 columns. It's only when you move to the "Info" tab in the Post that the column/size settings are respected.

    Just so we're comparing apples with apples... :)

  10. Forgot to highlight

    when displaying a Gallery when also using the Gallery post format at the same time

  11. Yes, I had switched all my posts over to 'standard' post format from 'gallery' format, as justjennifer had suggested to me, so they would appear correctly in the meantime.

    The problem does still occur if I switch the posts back to gallery post format.

    Thank you for checking into this.

  12. The problem that I'm having with Mixfolio is opening up the pictures. I can click and open a few but the rest all just show the title. I just switched to this theme because I could get the last one to work right either. I'm new to WordPress. Otherwise I really like it :)

    Appreciate any help.

  13. Hi, I'm back. I just noticed that on the pics that won't pop up when clicked there is a different little icon on it. On the pics that do open on a click one looks like a book. The pics that don't open on clicking has what looks little icon that looks like a floppy disk? If I go to the place that is blank but where the picture should be I can click image and it pops up HUGE :) I'm sure my descriptions are lame.
    Book/Floppy Disk? That is the question Who's on first.Thanks again.

  14. Yes, this all has to do with post formats.
    http://en.support.wordpress.com/posts/post-formats/

    The icons represent the different types. The single "polaroid" frame is an Image post format, double "polaroids" a Gallery post format, a book appears to be a Standard post format, a speech bubble a quote and so on. As you can tell, Image posts and Gallery posts have that three tab thing going on, although we not really sure what's going on there and why only some images show up on various tabs.

    You might be able to find more info on the theme showcase page and demo site.
    http://theme.wordpress.com/themes/mixfolio/
    http://mixfoliodemo.wordpress.com/

  15. Oh, and the pop up thing (Photo Carousel) only works on images inserted via the Gallery shortcode. http://en.support.wordpress.com/images/gallery/

  16. Thank you Jennifer :) I will try to do something with the Gallery shortcode.

Topic Closed

This topic has been closed to new replies.

About this Topic