Need help? Check out our Support site, then


More responsive b-quote button for HTML input

  1. In the HTML editing window, if I highlight a section of text and click b-quote, I get

    tags around my content, as I would expect, but also two lines before the
    and after. I suspect that this is in case someone is highlighting text that is part of a larger paragraph.

    I don't know how easy it would be, but it might be possible to check first, in the "macro", to see if the content is already in a block, and then not add the extra lines. Not that it requires more than deleting two lines, and I realize that whitespace doesn't matter in HTML, so they can always be left in ... however, I doubt that I am the only coder out there who likes to make his code neat and tidy.

    Hope all are well.

    The blog I need help with is humansongs.wordpress.com.

  2. LOL. Maybe I should try to remember not to include the tags themselves in the post? I'm talking about b-quotes. :-)

  3. The editor here has been broken like this for the 5+ years I've been here (and everywhere else that uses the TinyMCE editor). I've even seen bug reports in the trac listing at TinyMCE. Apparently no one thinks this needs fixing.

    I think after one or two revision cycles it becomes not a bug, but a feature.

    I'd like to see this fixed too as I have to follow around behind all my web clients and fix this, and a myriad of other TinyMCE editor bugs errr.... features, behind them all the time.

  4. The blank lines go away if you switch to Visual then back to HTML.

  5. A nifty trick, thanks.

  6. The visual editor does this as well. I've got all my clients set up to where wordpress automatically corrects XHTML (settings > writing) and I still have to pull out an extra paragraph with a non-breaking space it in at the beginning of blockquotes, and sometimes at the ends. Once in a while things work as they should, but more often than not... not.

Topic Closed

This topic has been closed to new replies.

About this Topic