Need help? Check out our Support site, then


Must login to comment?

  1. I have two blogs. In both the blogs, the options/discussions settings are the same. However in my blog, http://hirenshah.wordpress.com/ which is by the blog "Stray Thoughts", when you press on the comments box, it says, You must login to comment.

    However on my other blog, http://mypyp.wordpress.com/, when the comments is pressed, it shows a proper name box, an email box and comments box which is the way it should be.

    A lot of people have been complaining that my first blog does not allow to comment. I have not done anything to the configuration. Kindly make the the same configuration for the second blog valid for the first blog too or tell me how to do it. I want the same three boxes appearing in the first blog. I have had to hold my blogging till then.

    Most of your features are very good but operationally things are unnecessarily a little tough.

  2. I think I have discovered the solution myself. Under General options membership was ticked on. Actually a majority of configuration with comments is in the options discussion and that is where I was searching for. I could not figure out where I was going wrong.

    Can't help facing such problems, I suppose. Great software, neverthless.

  3. I've been using it for over a year now. I still don't know everything.

    Searching for stuff in the code on my end can be a pain as well.

    -drmike

  4. I am having the same problem. Users that do not have wordpress.com accounts cannot leave comments on my blog. All the options seem to be correct to allow comments - the membership one is unchecked and the "allow people to post" is checked. What else could be wrong!?

  5. Thanks for starting this thread! I was having the same problem and couldn't figure it out - but I had the "must be a member" option checked under the General Options tab. Oops!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags