Need help? Check out our Support site, then


MX Records for Google Apps

  1. I already have a Google Apps account. How do I add MX records on my WordPress.com domain manager? The domain's DNS records cannot be changed at GoDaddy because it's hosted here on WordPress.

    I tried Upgrades>Domains> and added the Google code, but that isn't working.

    Please help. I really need to set up an email for our organization's blog. Thanks!

    Blog URL: http://haitikidssoleilfoundation.org

    The blog I need help with is haitikidssoleilfoundation.org.

  2. Look through this section that explains how to set things up. I know Google made some changes, and I'm not sure if the support document has been updated to reflect those changes or not.

    http://en.support.wordpress.com/domain-mapping/custom-dns/#using-google-apps-for-domains

  3. I think I've tried everything already, but I'll try again. Maybe I missed something. Thanks again!

  4. Hi i am having similar problem. I already have a googlemail address not apps though and am wanting to use this. In the blurb it says something about choosing either a CNAME record HTML method. What does this mean?

  5. @hksf and @oceanheart10: Basically you need the verification code that Google Apps gives you (for example: googlexxxxxxx12345).

    Then, on WordPress.COM, go to Upgrades > Domains > (your domain) > Edit DNS > My verification code is (enter the code) > Generate DNS Records > OK (if a pop-up appears) > Save DNS Records. It should generate the correct CNAME, A, DNS and TXT records.

    Then go back to Google Apps to choose the CNAME verification method. Worked for me :-)

  6. Thanks! I did all of that and when it came time to verify on Google Apps, I still received error messages. I even went as far as trying with the html upload and, nothing at all! Any other suggestions? Please???

  7. My already existing Google Apps Options (only can add domain aliases):

    Add a DNS record to your domain's configuration
    You can use this option if you can sign in to your domain registrar or hosting provider and add a new DNS record.

    Add a meta tag to your site's home page
    You can choose this option if you can edit your site's HTML.

    Upload an HTML file to your server
    You can choose this option if you can upload new files to your site.
    (I chose this option to get the Google code).

    After clicking "Verify" button, this message appears:
    "HTML file Verification failed. Your verification file was not found."

    Sorry, but I thought it might help if I shared this. Thanks!

  8. @hksf: You can't do the HTML verification method because you cannot upload an HTML file to WordPress.COM. You need to tell Google Apps that you wish to verify via CNAME.

  9. It's probably what they mean by "Add a DNS record to your domain's configuration" (it covers CNAME and TXT):
    http://www.google.com/support/a/bin/answer.py?answer=47283

  10. I actually chose, "Add a DNS record to your domain's configuration" and when it did not work, GoDaddy suggested that I change the records on WordPress. I have no access to DNS records on GoDaddy since the domain is now hosted at WP.

  11. @hksf: Once you do the domain mapping at WordPress.COM, you change the DNS settings on WordPress.COM, not on GoDaddy, just like I said earlier.

    Would you like to copy and paste here your actual DNS settings on WordPress.COM (not GoDaddy!) as they appear under Upgrades > Domains > Edit DNS. That way, I could perhaps tell you what is not working. If you are not comfortable doing that, I'll suggest you contact WordPress.COM staff directly:
    http://en.support.wordpress.com/contact/

  12. I mentioned GoDaddy just to be certain that I let you know what I did try. Sorry for not being clear on that. My initial post still stands, I tried changing the records here on WordPress and could not verify on Google Apps. It's my understanding that you have to go back to Google Apps and verify. I only receive error messages.

    I don't mind sending it if it can be deleted. Is that possible? Thanks for being so patient!

  13. @hksf: Posts here are only deleted at the discretion of moderators.

    This is what I have on my DNS settings (there is no private information as you will see - I replaced my verification code with googlexxxxxxxxxxxxxxxx)

    MX 5 ALT1.ASPMX.L.GOOGLE.COM.
    MX 5 ALT2.ASPMX.L.GOOGLE.COM.
    MX 1 ASPMX.L.GOOGLE.COM.
    MX 10 ASPMX2.GOOGLEMAIL.COM.
    MX 10 ASPMX3.GOOGLEMAIL.COM.
    TXT v=spf1 include:aspmx.googlemail.com ~all
    CNAME googlexxxxxxxxxxxxxxxx google.com.

    If this is NOT what you see on your WordPress.COM DNS settings, change it and try verifying through Google Apps again.
    If this is already what's on your DNS settings, then contact staff.

    Thank you and best wishes.

  14. Thanks, but that is exactly what I did. I can't seem to get verified when I return to Google Apps to verify. I'll contact support to see what happens. Thanks for being so patient!

  15. You're welcome. Once the issue is fixed, it would be nice if you could report back on what was wrong. Perhaps this will help other people with a similar problem.

  16. CNAME googlexxxxxxxxxxxxxxxxgoogle.com.
    MX 5 ALT1.ASPMX.L.GOOGLE.COM.
    MX 5 ALT2.ASPMX.L.GOOGLE.COM.
    MX 1 ASPMX.L.GOOGLE.COM.
    MX 10 ASPMX2.GOOGLEMAIL.COM.
    MX 10 ASPMX3.GOOGLEMAIL.COM.
    TXT v=spf1 include:aspmx.googlemail.com ~all

    I thought I'd share after you took the initiative. I replaced the code with Xs. When I receive word from Support, I will also repost. Anyway, I added the records and if you'd like to, you can still try to help me. Thanks, again!

  17. I suppose there is a space between googlexxx... and google.com on your end, right?

  18. Spaces are only seen after CNAME and before google.com...

  19. OK good. I was asking because when trying to hide your verification code, you wrote googlexxx and google.com altogether.

  20. Ooops, sorry about that. I'll repost after hearing from support. Thanks!

  21. I've exhausted every resource possible and I've read every forum that I could find. I love WP, but a charity should not have to go through so much trouble to set up an inbox. The problem always lead back to the verification process on Google Apps not being completed because the domain is hosted here at WP.

    I had to delete my already existing Google Apps account and then created a brand new one to work with my organization's blog. I'm not sure if that will help anyone, but that's what I had to do.

    @airodyssey Thanks for all of your help.

    WP you are awesome, but please do something about the Google Apps issue!

  22. I've tagged this thread for staff attention. Hopefully they will read it and respond and either update the documentation here, or fix the issue whatever that happens to be.

  23. Hey, I figured it out you guys... (the automatic google apps verification thingie in the wordpress panel does not work). You have enter this in the larger box at the top of the panel... TXT, not CNAME, and DO leave the string of code that google gives you intact.

    MX 5 ALT1.ASPMX.L.GOOGLE.COM.
    MX 5 ALT2.ASPMX.L.GOOGLE.COM.
    MX 1 ASPMX.L.GOOGLE.COM.
    MX 10 ASPMX2.GOOGLEMAIL.COM.
    MX 10 ASPMX3.GOOGLEMAIL.COM.
    TXT google-site-verification=blahblahblah00000etc
    TXT v=spf1 include:aspmx.googlemail.com ~all

  24. wow! this works.. thanks hypsistarian!

  25. @hksf

    It looks like your site verification is missing from the values entered in the DNS Editor.
    We just published a complete guide for Google Apps email setup:

    http://en.support.wordpress.com/domain-mapping/google-apps-email/

    Could you try following these steps, especially steps 7-10?

  26. Thank you airodyssey for directing me here.

    @naokomc

    I have had the exact same issues mentioned in this string. And I am new to this, so did follow the steps in the link you provide above. What seems to be at issue is there is no option in Google to "change the CNAME" record - and the HTML file appears to not work because we're uploading the verification code minus .html as the file provides. At least this is where I seem to be stuck. I'm not familiar with either code or these terms, mx, cname, etc. Everything else I've done following the WP help files has worked out fine. I'm verified through Google using Meta tags, but cannot get this part accomplished.

    I also used the code provided by hypsistarian and Google is still not verifying through the HTML verification. I'm completely at a loss.

    Please help.

  27. I got it!!

    Using the following language in the DNS window:

    MX 5 ALT1.ASPMX.L.GOOGLE.COM.
    MX 5 ALT2.ASPMX.L.GOOGLE.COM.
    MX 1 ASPMX.L.GOOGLE.COM.
    MX 10 ASPMX2.GOOGLEMAIL.COM.
    MX 10 ASPMX3.GOOGLEMAIL.COM.
    TXT google-site-verification=blahblahblah00000etc
    TXT v=spf1 include:aspmx.googlemail.com ~all

    The TXT google-site-verification=(this number comes from the verification code line under "verify DNS" option in Google)

    You don't do anything with the HTML or CNAME. This piece is completely missing from the WordPress tutorial page. At least as far as I could see.

    You also don't "generate DNS records." Just copy and past the code listed above, adding in your own google-verification-code generated by the DNS verification option in the Google verification window.

    Hope this helps. Wow. Thank you everyone for your input - all the little pieces finally came together through trial and error.

  28. thanks jr1271, your input was the solution!

  29. @jr1271 - You're the man!

  30. @jr1271
    Yay! Thanks for providing that fix. Bookmarking! :)

Topic Closed

This topic has been closed to new replies.

About this Topic