Need help? Check out our Support site, then


MX Records not pointing to Zoho mail - checked with Zoho

  1. Hey guys, any help much appreciated.
    I bought my domain with GoDaddy, and then linked the domain to WordPress.com (and set the nameservers on GoDaddy to WordPress nameservers).

    I want people to be able to email me at [email redacted], through Zoho mail. I've verified my domain with Zoho, and the next step was to add MX records to get the emails to send to my Zoho address.
    I've checked with Zoho mail that my MX records are correct, however I'm still not receiving mail to my Zoho mail account.

    Here's what I've put in the domains bit in wordpress.com:
    DNS records:

    MX 10 mail.zoho.com.
    MX 20 mail2.zoho.com.
    TXT v=spf1 mx include:zoho.com ~all
    CNAME zb13893849 domain.zoho.com.

    Does this look right? Is there anything else that might need checking? I added these DNS records well over 48hrs ago, and I'm struggling to see why I'm still getting an error message in Zoho about MX records. Their support doesn't seem to be much help unfortunately, so I thought I'd post here. I've copied their settings exactly and checked multiple times.

    Many Thanks!

    The blog I need help with is guitartutorchris.co.uk.

  2. Hi there - Those look correct, except I don't think you need the TXT record. If your email still isn't working, try deleting that and re-saving?

    I'm not sure that that alone would stop your email from working, but worth a try. Otherwise everything looks good, so I'm afraid you'll need to contact Zoho again.

    If you're not wedded to using Zoho, setting up email forwarding is a simpler solution: Email Forwarding

Topic Closed

This topic has been closed to new replies.

About this Topic