Need help? Check out our Support site, then


My author link is using an obnoxiusly long Akismet ID instead of my username.

  1. My author link is using an obnoxiusly long Akismet ID instead of my username. Instead of using http://olowi.wordpress.com/author/vesq/ it uses http://olowi.wordpress.com/author/akismet-5658ab63338f501643676d51a8873714/.

    This also breaks the widget that displays all authors and links to their posts, because the widget displays links with href of /author/vesq/.

    It seems to be the same problem as described here: http://en.forums.wordpress.com/topic/author-link-url?replies=3
    Blog url: http://olowi.wordpress.com/

  2. Gravatar IDs
    Do you have a funny looking username assigned through Gravatar that starts with g2-* ?
    If so, this was made when an imported Gravatar account had an email address not matching an account with WordPress.com. Please login to WordPress.com and then visit http://wordpress.com /wp-changelogin.php to change this username. http://en.support.wordpress.com/change-your-username/

  3. I'm sorry and I apologize. I didn't read closely and provided a wrong answer above. This thread is now flagged for a Staff response.

  4. Hi timethief, and thanks for the response. I was just about to write you a response for giving a wrong answer. Thanks for flagging this thread.

  5. I'm sorry. I'm speeding along as fast as I can as I must go out soon and do the shopping.

  6. Thats 100% okay, no worries. This isn't a huge critical issue, rather just an annoyance, so I'm fine with delays or some simple human errors :)

  7. For some reason, that was set as your nickname. You can change it at Users -> Personal Settings in your blog's Dashboard.

  8. Thanks for the response, but somehow the nickname shows up as "vesq" correctly in the dashboard and I can't change it after clicking the "Change" link because the name really doesn't change.

    Here's a picture of the dashboard with personal stuff deleted. It's in finnish but I hope you can identify which parts are what.

    https://dl.dropbox.com/u/38940252/random/wordpresscom_weirdosities.png

  9. And now I changed it to English but still the same outcome: https://dl.dropbox.com/u/38940252/random/wordpresscom_weirdosities-eng.png

  10. Oh, I'm sorry, I gave you the wrong location.

    Don't worry, I took care of it for you.

  11. Well that was very kind of you, thanks. Does it take some time to be effective? Because right now it is not working, http://olowi.wordpress.com/author/vesq/ gives 404 and the http://olowi.wordpress.com/author/akismet-5658ab63338f501643676d51a8873714/ is the only one that works.

  12. It should take a few hours for the cache to clear.

  13. Ah, great, thanks. I'll mark this as resolved after it's working :)

  14. You're welcome!

  15. It's been 12 hours since the change was made but still the problem exists. Any new ideas?

  16. Do you have any luck if you edit a post and change the author to someone else, then back to you?

    You can do this near the bottom of the post edit page in the Author box.

    If you don't see the Author box, click the Screen Options tab near the top-right and make sure that "Author" is checked.

  17. Nope, I tried to change one post but it made no difference.

  18. Ok, if you quickly publish a test post, does it go under the correct author link?

    If you'd rather not do that, would you mind waiting until your next normal post?

  19. Ok, feel free to delete that.

    I'm out of ideas myself, so I'm going to pass this up the chain and see if we can get some more eyes on it.

  20. It can lay there, I'm sure it might be of help to someone further up the chain. This truly does sound like a weird bug.

    Let me know if I can be of any help. PHP and WordPress code is not an oddity to me, I've done my share of coding themes and such in last two years so if the discussion has to get technical, I can handle it.

  21. No need for anything else yet. We'll let you know when we've found a solution.

    Sorry for the trouble!

  22. That's okay, I'm happy helping to make wordpress.com even better :)

  23. Ok, you're all fixed up now.

    Please let us know if you need any further assistance!

  24. Yup, it does work splendidly now. Thank you for all your help! :)

  25. Great - glad macmanx was able to get this sorted out.

Topic Closed

This topic has been closed to new replies.

About this Topic