Need help? Check out our Support site, then


my blog is invisible in the google search engines

  1. I created my blog few days ago. I have selected to be visible to everyone and all the search engines. Unfortunately it doesn't seem to be visible to anyone and when I google it it doesn't appear anything. What I do wrong ?

    The blog I need help with is nmspace.wordpress.com.

  2. Be patient. Write more posts. Use categories.

  3. Okay, what if I had the opposite problem: I'd prefer my stats to only reflect personal visitors (but don't want to endure the hassle of setting up passwords, limiting to 35 users, etc.). I am hit by the same search terms nearly everyday, MANY times a day, which link to one image I posted (and later took down.) I set my privacy controls to block search engines, but have yet to notice a change.

    What can I do??

  4. You could try changing the url of that post. On the editing page, click the edit button next to the url and put in something different. That way, the existing links will take people to an error message. You'll still see the hits in your overall figures for a while, though.

  5. The "no search engines" privacy option means that search engines will no longer index your site. It doesn't affect material that they have already indexed. It's an advisory preference only, and not a guaranteed privacy measure - that's what the password protected options are for.

    nmspace: your blog is in Google now - http://ismyblogworking.com/nmspace.wordpress.com

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.