Need help? Check out our Support site, then


My comments are considered SPAM

  1. This problem has appeared recently. I used to post comments normally, but now even when I post comments to my *own* blog, they do not appear, and I find them in the SPAM filter list. I have comment moderation disabled, have no spam words, or whatsoever. Even comments with 2 or 3 simple words do not appear. I've even tried 'testing commenting'.. and yet I found it was considered Spam.

    I've tried to uncheck 'Blacklist comments from open and insecure proxies.', but all in vain.

    Btw, I get a security warning everytime I post saying, "You're about to be transfered to a nonsecure site. Do you want to continue?", so I click YES, and just nothing happens, except finding my comment in the spam folder.

    I use Win XP Pro SP1, IE 6, Security settings set as 'Medium-Low', and Privacy set to 'Low'.

    Any thoughts?!?

  2. Comments and trackbacks from WP.com hosted blogs are showing up as spam as well on my blog and the blogs I host as well hosted off of site. I'm voting for the IP address it's coming from. I know I'm seeing a fair amount of spam on my personal blog out of WP.com space.

    *chuckle* I think it's funny myself. A serious issue but kind of funny if you think about it. :)

    Instructions say to mark them as non-spam and click on the non-spam button. I do hope you are doing this. Those reports do get reported to Akismet. Maybe a feedback would help as well. (What would really help is a report on why they are showing up as spam. Of course that would publicize why they are being tagged as spam and allow spammers a way to configure how to get around it.)

    As to your other settings, they should be back on the defaults. Proxies are something entirely different. That one should be checked though.

    As to the security warning, you should be clicking on yes. When you're on your backend, some of the pictures are not via https. That's why you're getting that. (This has been discussed a few times here.) If you want to see which ones if your curious, pull up the page's source code and do a search for http://. Was discussed as well when the secure backends were rolled out.

    Hope this helps,
    -drmike

  3. drmike,

    Well, by the time I read your post, I had already done what you advised me except setting my security settings back to default. And guess what..?! After doing that, it worked! I could post comments to my blog.. haven't tried it in other blogs yet, but I guess it's gonna work.

    Thanks a lot!

  4. What would really help is a report on why they are showing up as spam

    As I understand it, Akismet relies on users flagging comments and TBs as spam; so either sploggers have been making spam comments with a wordpress.com url attached, or they've been 'poisoning the well' by marking anything wordpress.com-connected as spam.

    That, or it's a glitch.

  5. It's definitely a glitch, I'm looking into it.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags