Need help? Check out our Support site, then


My comments have been turned off...

  1. but, not by me. Not sure why...how can I turn it back on? All of the discussion settings look fine.

    The blog I need help with is bethcerronebs.wordpress.com.

  2. I visited the blog linked to your username as well as the other one linked to in the OP and comments are open on both blogs.

    Comments on all pages and posts on every WordPress blog are enabled by default. This page > Settings > Discussion
    Discussion settings is where you set up defaults for comments.
    http://en.support.wordpress.com/settings/discussion-settings/

    We can also override the default settings and enable or disable future comments on any individual post or page.
    http://en.support.wordpress.com/enable-disable-comments/

    Note: By default, new blogs on WordPress.com will have the Discussion hidden. You can reveal it by clicking on Screen Options http://en.support.wordpress.com/screen-options/ on the top right corner of your Admin page, and checking the box that says Discussion so the module is included. http://en.support.wordpress.com/modules/#list-of-modules

Topic Closed

This topic has been closed to new replies.

About this Topic