Need help? Check out our Support site, then


My site appears to be blocking Google

  1. dynamicosteopaths
    Member

    My site seems to be verified just fine (under blog.dynamicosteopaths.com) within Google webmaster, However, when opening this file errors seem to appear, which i can not get rid of. Examples; URL error - crawl error, URL points to a non-existent page 404 (Not found). Couldn't communicate with the DNS server. Request timed out or site is blocking Google. Crawl postponed because robots.txt was inaccessible.

    I have tried to learn how to deal with this, but I got hugely confused.

    Can you please assist me with this as at the moment, when I try and search for my search within Google, it is non-existent?? Should I put dynamicosteopaths.wordpress.com in webmaster instead of blog.dynamicosteopaths.com?

    Many Thanks

    Adam

    The blog I need help with is blog.dynamicosteopaths.com.

  2. The best thing you could possibly do to help your blog's Google ranking is to post more. They only index sites that have content they think someone is searching for; the more you post, the more Google gets alerted to your existence.

    Also, what is going on with THIS blog: http://www.dynamicosteopaths.com/#!osteopath-blog-solihull/c6f6 ? You should delete it and change the link to link to your subdomain if that's where you want the blog. Otherwise Google is trying to figure out which of the two sites is teh actual blog and is ranking the most established one instead of yours.

  3. dynamicosteopaths
    Member

    Thanks very much for your reply. The one which you are referring to is a blog I have attached to my website. This is in addition to my WordPress blog also. I thought it may help. What would you suggest I do? How can I possibly integrate the two (my WordPress blog and my website)? You mentioned changing the link to link to my sub domain… What do you mean here? I will do whatever is most beneficial.

    Again, really appreciate your help.

  4. It's most beneficial for your WEBSITE to host a blog in its own webspace, using WordPress.org software. But you should change that link to the subdomain blog.dynamicosteopaths.com instead of that long, pointless URL. That alone will be interfering with your Google rank.

    I see no point to having two blogs. I advise you to use WP.org software to blog on your own website and set teh blog here to Private. You can just change where the subdomain points, so that it goes to your website's blog rather than the site here at Wp.com.

  5. dynamicosteopaths
    Member

    Okay, I think I understand - I need to change http://www.dynamicosteopaths.com/#!osteopath-blog-solihull/c6f6 to blog.dynamicosteopaths.com right? And then my WP account should operate from my website, is this correct? I am very new to this, currently using Wix.com for my site and they have there own app called EASY SEO BLOG which you are currently seeing.

    Thanks

  6. No. That's not exactly correct. I recommended installing software from WordPress.org in your webspace and using that for the blog, but I'm not sure you can do that with Wix.

    If you change the link to http://blog.dynamicosteopaths.com then the link will take people off your website to your WordPress.com blog. Your old blog will go POOF! That's the simplest solution, but it's not the very BEST for your website. The BEST solution is the one I outlined above, but again I'm not sure it's possible to embed a WordPress blog in a Wix website.

  7. dynamicosteopaths
    Member

    Thanks again. I am going to try an do what you have suggested. I have just contacted WIX to see if I can change the link. On the other note, you mentioned about installed WP.org software. I believe I have just downloaded this from WP.org site, but I am unsure what I need to do with it, as I can't yet open it. Any suggestions?

  8. To find advice about how to use WP.org, you need to be at WordPress.org.

  9. dynamicosteopaths
    Member

    Hi again,

    My blog (blog.dynamicosteopaths.com) is still not appearing on Google, even when putting in the search of 'blog dynamic osteopaths'. Is there a reason for this?? I have altered all of my settings and nothing seems to work. You could advise I would be extremely grateful.

    Thanks, Adam.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.