Need help? Check out our Support site, then


my stats aren't loading

  1. my stats aren't loading, not the old page or the new; the loading circle just keeps spinning forever
    Blog url: http://formerheathen.wordpress.com/

  2. Hi, I'm having this problem also. I just sent in a request for help to the support team. The problem started for me yesterday, June 14.

  3. Hello there,
    Note that there are several active threads on this stats page not loading issue.

    If you are using Google Chrome read this please > http://en.forums.wordpress.com/topic/stats-graph-not-displaying-on-chrome?replies=14#post-914200

    These are the troubleshooting steps we take whenever any issues like this arise:
    clearing your browser cache and cookies > http://www.google.com/support/accounts/bin/answer.py?hl=en&answer=32050
    using the browser with all extensions or add-ons disabled
    updating the browser to the latest stable version (not a buggy BETA browser version) http://browsehappy.com/
    confirming third party cookies is enabled http://support.google.com/accounts/bin/answer.py?hl=en&answer=61416
    confirming JavaScript is enabled http://www.google.com/adsense/support/bin/answer.py?answer=12654
    confirming Flash is updated http://www.adobe.com/software/flash/about/ and if required installing the latest version of Flash http://www.adobe.com/products/flashplayer/
    resetting your router and modem and rebooting your computer
    then logging in using the secure https:// log-in see http://en.support.wordpress.com/https/
    trying another browser

    If those do not work for you then we need to know
    (1) How are are connecting to the internet and to WordPress.com? The way you connect to the internet (mobile, satellite, DSL, dial-up) and to your blog, and how many proxy server jumps etc. it takes to connect can cause problems. There maybe be problems with your ISP and/or with the proxy servers. Also note that the main dashboard isn’t designed to work with touch devices through the tablet and smartphone browsers.

    (2) Exactly which browser and version of it are you using. If you don’t know click here to find out > http://whatsmyuseragent.com/

  4. We're aware of the issue and working on a solution.

    Sorry for the trouble!

  5. @formerheathen and @rmanees -- can you confirm whether your stats are working now?

  6. Mine are working fine now-thanks!! :-)

  7. I disabled the Firebug 1.9.2 and personas 1.6.2, cleared cache and cookies and stats/notifications are working properly again. Page even loads completely now! Thanks!

  8. My stats are also loading properly now. Thank you!

Topic Closed

This topic has been closed to new replies.

About this Topic