Need help? Check out our Support site, then


"My Stats" page not loading: "javascript:void(null)"?

  1. maureenholland
    Member

    I've been experiencing the problem for almost a month now. Cleared the cache etc but that didn't make any difference.

    I have faith WordPress - you'll resolve it! You always do.

  2. We have the same problem. No blue bars, although the totals are under the graph text area.

  3. still going on..... comes and goes... driving me nuts...

  4. @lovethebadguy, exactly right, and add to that that getting the right info to the right people is key—because sometimes the problem is tricky or happening just under some circumstances that the support team should try to work with you to figure out the steps to reproduce the issue. The more specific/detailed info you guys can post about how to reproduce the problem in your environment (such as browser version or specific Javascript errors) the better. :) What we probably really need is someone with a little advanced tech knowledge (or willingness to learn!) who can reproduce the problem to post related Javascript errors from their Chrome or Firebug console that pinpoint what file or function is the culprit or provide us with a specific error message.

    Side note: clearing cache is often a good thing to try even if you've already tried it once before because it will ensure you are looking at the latest changes if developers have made updates since the last time you tested—this is often why we ask to try clearing cache more than once.

    Another thing about long threads… since at least one stats bug that was originally reported in this thread was found and fixed on 6/18, we need new info posted from later reporters because it could be a separate bug and it's hard to separate out all the reports once a thread gets super long like this one has gotten.

    I have the same issue, using IE9, both going directly to wordpress & hitting the stat button, or using a URL. Cleaning the cache doesn't help.

    @drjbn, it's been a while since you posted about this (20 days), can you reply back if you're still experiencing trouble with the "yesterday" links with the WordPress.com home page Stats tab?

    I have same issue when ever I click on yesterday I get Page not found. This is quite annoying I cant access my stats other than current day. Tries everything clearly this is a wordpress issue.

    @infowomen, based on your feedback, I tried these steps but I couldn't reproduce the the problem you described:

    1. Go to http://wordpress.com/ and log in
    2. Click on the Stats tab
    3. Click on "Yesterday" under "Views by Country" and under "Referrers"
    * Result: When I click on yesterday, the proper stats load correctly for me.
    * I tested with Firefox 15.0.1 on a Mac and IE9 on Win7.

    Can you think of anything differently you're doing compared to my steps? What about browser version, which version are you using?

    We have the same problem. No blue bars, although the totals are under the graph text area.

    @ppjg, just to make sure, have you tried clearing your browser cache recently or perhaps can you check from an alternate browser you don't normally use just to see if the problem is limited to one type of browser in your case?

    @chuckieb123, would you be willing to give looking for Javascript errors in a browser's console a try? What browser and browser version are you using?

  5. Also, I'll keep trying to test when you guys post back with more info—if I can trigger the problem, then I should be able to get the info I need to pinpoint what might need to be fixed on our side.

  6. I believe I have found the problem for me. I have IE8 and found the 'compatibility mode' has to be turned 'off' for it to 'connect.' It is undoubtedly the compatibility mode that also causes some people to be able to access it and other not to be able to.

  7. I've been having this problem for months via multiple computers, browsers, and operating systems. Visiting wordpress.com displays a fine, working view. But viewing stats from within my hosted blog URL results in the continual spinning. Here's the URL I use:

    http://www.myblog.com/wordpress/wp-admin/admin.php?page=stats

  8. I should also add that in addition to the spinning, sometimes there's no spinning and no bars, and rarely can I click on the tabs or expand the plus marks.

  9. If you are not running one of the browsers and versions listed at http://browsehappy.com/ please try upgrading or switching first.

    Note: If you are using an IE9 browser in compatibility mode that makes it render as IE7 and IE7 is not supported. To disable see > http://www.sevenforums.com/tutorials/1196-internet-explorer-compatibility-view-turn-off.html

    If you are running one of the browsers and versions listed at http://browsehappy.com please do these things:

    1. Try clearing your browser’s cache http://www.google.com/support/accounts/bin/answer.py?hl=en&answer=32050

    2. Make sure that you have third-party cookies enabled http://en.support.wordpress.com/third-party-cookies/

    3. Enable JavaScript http://www.google.com/adsense/support/bin/answer.py?answer=12654

    4. Try with all browser extensions or add-ons temporarily disabled.

    5. Try enabling HTTPS: http://en.support.wordpress.com/https/

    If you are not successful let us know which browser (and version of it) you’re using and post any error reports you get.

  10. I've seen this issue on current versions of Chrome, Firefox, and Safari on Windows 7 and OS X. I'm on Mountain Lion tonight and confirm the issue is there under Safari and Chrome. On Chrome, I confirmed cookie and JavaScript are enabled - assume they are on my other platforms as well. I also cleared the cache, cleared the cookies, unlinked/relinked Jetpack and the issue persists. I don't think the problem is in the browser...

  11. I've seen this issue on current versions of Chrome and Firefox on Windows XP and Ubuntu Linux 12.04.

  12. I don't know what's been "fixed" -- I have been getting the swirling blue circle of no data for about a week now. I'm running Firefox 17.0.1.

  13. maureenholland
    Member

    kbassler: I've had he endless blue circle a few times; once it went on for weeks. I really didn't make any changes except clearing out my cache once - which made no difference. Then, one day, the problem just disappeared. No idea why. All has been well for a few moonths now.

  14. I have had this problem for the last couple of days with Firefox on a Mac. Your page directed me to the Mozilla help page which suggested clicking on the red fireplug icon. Only problem is this icon isn't on my page. What do I do?

  15. maureenholland
    Member

    @standinsand - I don't know the answer. All I can tell you is that, as with so many WordPress glitches, it eventually self corrects! It did for me. Good luck.

  16. I also have this same problem.

  17. I've done all of the things advised in this thread and others (cleared cache, disabled plugins, deleted all cookies, forced refresh, restarted several times, restarted computer, changed to https:// etc.) and I also have the same spinning circle as everyone else. This has been happening for weeks. I initially thought it might be the Java issue but it's still going on even after the fix (I also tried disabling all plugins). I cannot get to Stats, Reader, My Blogs, Freshly Pressed, or "The Big W" (Following), and on the right hand side New Post, Latest Notifications - or anything under my gravatar photo - EXCEPT for the link to one of my blog's admins. All links begin with /#!/

    I am using Firefox 19.0. I tried IE and could get to the stats there but I don't use IE. I can also get to my stats via iPhone app. But really, it would be nice to be able to actually use the entire Dashboard from my office. My blog is quiltsofaliasgrace.wordpress.com

    If there's anything I can do to help get this fixed, any info or screenshots, please let me know. Hope this is resolved soon! THANKS! :)

  18. Reinstalling Firefox (at the suggestion of a tech support person on WordPress) worked to fix it for me. You can go to the Mozilla web site to find out how.

  19. For anyone still reporting the problem where you are unable to load stats using the https://wordpress.com/#!/my-stats/ link, please consider trying to capture some debugging information for us. What would be helpful to know is if you can see any errors get logged in Firebug's console window during the time you load the stats page.

    If you are willing to help out, here's what you can do:

    1. Install Firebug: http://getfirebug.com/
    2. Go to https://wordpress.com/#!/my-stats/
    3. Open Firebug and reload the stats page
    4. Click "Console" and then "Errors" inside Firebug
    5. If you see any errors, take a screenshot, upload it to your blog, and reply here with a link to the screenshot.
    http://en.support.wordpress.com/make-a-screenshot/

    I know that's a lot of steps! Since I am unable to reproduce the problem myself, I need to rely on you guys to help provide the data required to debug this issue. So if anyone can spot any load time errors and send screenshots of them, that would be a step in the right direction.

    I created a screenshot myself. I actually see two errors when I open the stats page in Firefox, but my stats still load just fine and I don't see an endless spinner graphic like some of you have described.

    http://cl.ly/NEin

  20. I'm happy to help out! I've uploaded my screengrab here:
    http://wp.me/a1RNA5-bT

    The error I'm showing is:
    TypeError: localStorage is null
    get: function( key ) { return localStorage.getItem( key + localstorageHash ); }<br />
    ...on line 2508.

    I hope this helps! :) Please let me know if I can add anything, answer any questions, send more info, etc. Thanks for looking into this!

  21. I have implemented a workaround for this problem in Firefox. Could you please try loading the stats page again?

    This is actually a bit of a nasty Firefox bug, that you may run in to on other sites. There is a fairly simple way to fix it:

    1. Type in about:config in your address bar and hit enter (if you see a warning don't worry, just hit the button).
    2. You should see a list of settings.
    3. In the search box type: dom.storage.enabled
    4. You should see one entry in the list. Under the "Value" column you should see "false".
    5. Double click on "false" and it should change to "true".

    That's it, you can close that tab, the bug is fixed. :)

  22. That's it, you can close that tab, the bug is fixed. :)

    Yes indeed it is! Perfect :) THANK YOU!

Topic Closed

This topic has been closed to new replies.

About this Topic